summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2023-08-20 16:45:36 -0400
committerDarvin Delgado2023-08-20 16:45:36 -0400
commita28043c1ad45cca151964572fcf3365176baf3ef (patch)
tree75a3e257a35cb91a81d7d7be4a0febe100c160a5
downloadaur-a28043c1ad45cca151964572fcf3365176baf3ef.tar.gz
first commit
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD40
-rw-r--r--rom-properties-git.install15
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..540a5e33c0eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = rom-properties-git
+ pkgdesc = This shell extension adds a few nice features to file browsers for managing video game ROM and disc images.
+ pkgver = 2.2.1.r243.gd8dd8cf
+ pkgrel = 1
+ url = https://github.com/GerbilSoft/rom-properties
+ install = rom-properties-git.install
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = pkgconf
+ makedepends = gettext
+ depends = curl
+ depends = zlib
+ depends = libpng
+ depends = libjpeg-turbo
+ depends = nettle
+ depends = tinyxml2
+ depends = libseccomp
+ optdepends = zstd
+ optdepends = lz4
+ optdepends = lzo
+ conflicts = rom-properties
+ replaces = rom-properties
+ source = git+https://github.com/GerbilSoft/rom-properties
+ source = rom-properties-git.install
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = rom-properties-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ddd55c968bf2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+rom-properties/
+src/
+pkg/
+*.tar.zst
+*.tar.gz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f558cde309e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
+
+pkgname=rom-properties-git
+pkgver=2.2.1.r243.gd8dd8cf
+pkgrel=1
+pkgdesc='This shell extension adds a few nice features to file browsers for managing video game ROM and disc images.'
+arch=('x86_64')
+url='https://github.com/GerbilSoft/rom-properties'
+license=('GPL2')
+depends=('curl' 'zlib' 'libpng' 'libjpeg-turbo' 'nettle' 'tinyxml2' 'libseccomp')
+optdepends=('zstd' 'lz4' 'lzo')
+makedepends=('cmake' 'pkgconf' 'gettext')
+replaces=('rom-properties')
+conflicts=('rom-properties')
+source=(
+ "git+$url"
+ "rom-properties-git.install"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP')
+install=rom-properties-git.install
+
+pkgver() {
+ cd "${pkgname%%-git}"
+ git describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir -p build && cd build
+ cmake $srcdir/${pkgname%%-git} -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBEXECDIR=lib/${pkgname%%-git} -DCMAKE_BUILD_TYPE=Release -DSPLIT_DEBUG=OFF
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+
+ make DESTDIR="$pkgdir" install
+}
+# vim:set ts=2 sw=2 et:
diff --git a/rom-properties-git.install b/rom-properties-git.install
new file mode 100644
index 000000000000..2d8da34fcda3
--- /dev/null
+++ b/rom-properties-git.install
@@ -0,0 +1,15 @@
+post_install() {
+ if command -v kbuildsycoca5 &> /dev/null
+ then
+ echo 'kbuildsycoca5 running...'
+ kbuildsycoca5 --noincremental &> /dev/null
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}