summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoa Himesaka2023-11-01 19:23:14 +0900
committerNoa Himesaka2023-11-01 19:27:33 +0900
commit1fd0496298424831f07ef3df3022a028e4697d98 (patch)
tree5004eef3b42a7352a8e117afdbfeff17f86863fe
downloadaur-1fd0496298424831f07ef3df3022a028e4697d98.tar.gz
roon-tui: A Roon Remote for the terminal
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD28
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a0199aea1b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = roon-tui
+ pkgdesc = A Roon Remote for the terminal
+ pkgver = 0.0.7
+ pkgrel = 1
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cargo
+ source = git+https://github.com/TheAppgineer/roon-tui.git
+ sha256sums = SKIP
+
+pkgname = roon-tui
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b73905529f23
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87fa0a520321
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Noa Himesaka <himesaka AT noa DOT codes>
+pkgname=roon-tui
+pkgver=0.0.7
+pkgrel=1
+pkgdesc="A Roon Remote for the terminal"
+arch=('x86_64')
+license=('MIT')
+makedepends=('git' 'cargo')
+source=("git+https://github.com/TheAppgineer/roon-tui.git#tag=$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+package() {
+ # Install binary
+ install -Dm755 "$pkgname/target/release/roon-tui" "$pkgdir/usr/bin/roon-tui"
+}