summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Gizdov2018-09-20 18:51:26 +0200
committerKonstantin Gizdov2018-09-20 18:51:26 +0200
commit352ea9a8386f060660c6aacb23ca3c88195abe86 (patch)
treea4ae800ad63208fb287958772098da1742bc662c
parent655abd58dc6dfd4f4df33e2f794234eb3995328e (diff)
downloadaur-352ea9a8386f060660c6aacb23ca3c88195abe86.tar.gz
update to v6.14.04
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--fix_pyroot_for_python3.7.patch67
3 files changed, 5 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 582e078f492f..b158e61bd939 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = root
pkgdesc = C++ data analysis framework and interpreter from CERN.
- pkgver = 6.14.02
+ pkgver = 6.14.04
pkgrel = 1
url = http://root.cern.ch
install = root.install
@@ -40,21 +40,19 @@ pkgbase = root
optdepends = xrootd: XRootD support
optdepends = z3: Z3 Theorem prover support
options = !emptydirs
- source = https://root.cern.ch/download/root_v6.14.02.source.tar.gz
+ source = https://root.cern.ch/download/root_v6.14.04.source.tar.gz
source = root.install
source = root.sh
source = root.xml
source = rootd
source = settings.cmake
- source = fix_pyroot_for_python3.7.patch
source = fix_tmva_numpy_dependency.patch
- sha256sums = 93816519523e87ac75924178d87112d1573eaa108fc65691aea9a9dd5bc05b3e
+ sha256sums = 463ec20692332a422cfb5f38c78bedab1c40ab4d81be18e99b50cf9f53f596cf
sha256sums = 72ba38e0faffa084ac2f787f360201f72b1733d27e36c3cb88eb2f3a4716fa61
sha256sums = 9d1f8e7ad923cb5450386edbbce085d258653c0160419cdd6ff154542cc32bd7
sha256sums = 50c08191a5b281a39aa05ace4feb8d5405707b4c54a5dcba061f954649c38cb0
sha256sums = 3c45b03761d5254142710b7004af0077f18efece7c95511910140d0542c8de8a
sha256sums = 0a614a23794495d917fc4060d184be06e78fde5f5e343b70920c77a80ae0abbf
- sha256sums = 1861c566c1748fd9a486800a2a806589a7b88a9c20cb76b59ac1ccc34ef60b57
sha256sums = bc0a31992c0da5004d6d9be8f0236e77185245f218ec49a6d86d9279c7bbb868
pkgname = root
diff --git a/PKGBUILD b/PKGBUILD
index c2c513c68002..0110861187bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Sebastian Voecking < voeck at web dot de >
pkgname=root
-pkgver=6.14.02
+pkgver=6.14.04
pkgrel=1
pkgdesc='C++ data analysis framework and interpreter from CERN.'
arch=('i686' 'x86_64')
@@ -51,15 +51,13 @@ source=("https://root.cern.ch/download/root_v${pkgver}.source.tar.gz"
'root.xml'
'rootd'
'settings.cmake'
- 'fix_pyroot_for_python3.7.patch'
'fix_tmva_numpy_dependency.patch')
-sha256sums=('93816519523e87ac75924178d87112d1573eaa108fc65691aea9a9dd5bc05b3e'
+sha256sums=('463ec20692332a422cfb5f38c78bedab1c40ab4d81be18e99b50cf9f53f596cf'
'72ba38e0faffa084ac2f787f360201f72b1733d27e36c3cb88eb2f3a4716fa61'
'9d1f8e7ad923cb5450386edbbce085d258653c0160419cdd6ff154542cc32bd7'
'50c08191a5b281a39aa05ace4feb8d5405707b4c54a5dcba061f954649c38cb0'
'3c45b03761d5254142710b7004af0077f18efece7c95511910140d0542c8de8a'
'0a614a23794495d917fc4060d184be06e78fde5f5e343b70920c77a80ae0abbf'
- '1861c566c1748fd9a486800a2a806589a7b88a9c20cb76b59ac1ccc34ef60b57'
'bc0a31992c0da5004d6d9be8f0236e77185245f218ec49a6d86d9279c7bbb868')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -67,7 +65,6 @@ prepare() {
msg2 'Adjusting to Python3...'
2to3 -w etc/dictpch/makepch.py 2>&1 > /dev/null
- patch -p1 -i "${srcdir}/fix_pyroot_for_python3.7.patch"
patch -p1 -i "${srcdir}/fix_tmva_numpy_dependency.patch"
mkdir -p "${srcdir}/build"
diff --git a/fix_pyroot_for_python3.7.patch b/fix_pyroot_for_python3.7.patch
deleted file mode 100644
index b8f4a1c1fe65..000000000000
--- a/fix_pyroot_for_python3.7.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 94412f7eab8d2cbdb4c83cd29215e7e2b185640f Mon Sep 17 00:00:00 2001
-From: Mattias Ellert <mattias.ellert@physics.uu.se>
-Date: Sat, 30 Jun 2018 21:27:57 +0200
-Subject: [PATCH] Fixes for Python 3.7
-
- * PyROOT_PyUnicode_AsString changed return type from char* to const char*
- * Using _PyObject_GC_TRACK results in linking error:
- undefined reference to `_PyGC_generation0'
- The python documentation says this about _PyObject_GC_TRACK:
- "A macro version of PyObject_GC_Track(). It should not be used for
- extension modules."
- So it should not be used. Calling PyObject_GC_Track instead avoids the
- undefined symbol. I also removed the #ifndef R__WIN32 since the
- comment indicates that this was added to avoid the same issue on
- windows. Calling PyObject_GC_Track instead of using the
- _PyObject_GC_TRACK macro should fix the undefined symbol probelem on
- windows too.
----
- bindings/pyroot/src/PyRootType.cxx | 2 +-
- bindings/pyroot/src/Pythonize.cxx | 4 +---
- bindings/pyroot/src/TPyROOTApplication.cxx | 2 +-
- 3 files changed, 3 insertions(+), 5 deletions(-)
-
-diff --git a/bindings/pyroot/src/PyRootType.cxx b/bindings/pyroot/src/PyRootType.cxx
-index 3c2719c..0edc2e8 100644
---- a/bindings/pyroot/src/PyRootType.cxx
-+++ b/bindings/pyroot/src/PyRootType.cxx
-@@ -100,7 +100,7 @@ namespace {
- if ( ! attr && ! PyRootType_CheckExact( pyclass ) && PyType_Check( pyclass ) ) {
- PyErr_Clear();
- PyObject* pycppname = PyObject_GetAttr( pyclass, PyStrings::gCppName );
-- char* cppname = PyROOT_PyUnicode_AsString(pycppname);
-+ const char* cppname = PyROOT_PyUnicode_AsString(pycppname);
- Py_DECREF(pycppname);
- Cppyy::TCppScope_t scope = Cppyy::GetScope( cppname );
- TClass* klass = TClass::GetClass( cppname );
-diff --git a/bindings/pyroot/src/Pythonize.cxx b/bindings/pyroot/src/Pythonize.cxx
-index f6b1016..c6e7108 100644
---- a/bindings/pyroot/src/Pythonize.cxx
-+++ b/bindings/pyroot/src/Pythonize.cxx
-@@ -977,9 +977,7 @@ namespace {
- vi->vi_len = vi->vi_pos = 0;
- vi->vi_len = PySequence_Size( v );
-
--#ifndef R__WIN32 // prevent error LNK2001: unresolved external symbol __PyGC_generation0
-- _PyObject_GC_TRACK( vi );
--#endif
-+ PyObject_GC_Track( vi );
- return (PyObject*)vi;
- }
-
-diff --git a/bindings/pyroot/src/TPyROOTApplication.cxx b/bindings/pyroot/src/TPyROOTApplication.cxx
-index 4f624a7..c47596e 100644
---- a/bindings/pyroot/src/TPyROOTApplication.cxx
-+++ b/bindings/pyroot/src/TPyROOTApplication.cxx
-@@ -98,7 +98,7 @@ Bool_t PyROOT::TPyROOTApplication::CreatePyROOTApplication( Bool_t bLoadLibs )
- if ( argl && 0 < PyList_Size( argl ) ) argc = (int)PyList_GET_SIZE( argl );
- char** argv = new char*[ argc ];
- for ( int i = 1; i < argc; ++i ) {
-- char* argi = PyROOT_PyUnicode_AsString( PyList_GET_ITEM( argl, i ) );
-+ char* argi = const_cast< char* >( PyROOT_PyUnicode_AsString( PyList_GET_ITEM( argl, i ) ) );
- if ( strcmp( argi, "-" ) == 0 || strcmp( argi, "--" ) == 0 ) {
- // stop collecting options, the remaining are for the python script
- argc = i; // includes program name
---
-2.7.4
-