summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Gizdov2018-06-15 16:26:47 +0200
committerKonstantin Gizdov2018-06-15 16:26:47 +0200
commitf19fec5b7fae5fa8f3aed798fa1733eb8d303ecc (patch)
tree6ec689ae6cb4a384f849ed129a29ed5f48467d01
parentaa1e7b33b9ded7e03ec1b3c7cae35f7f5bc3a6bc (diff)
downloadaur-f19fec5b7fae5fa8f3aed798fa1733eb8d303ecc.tar.gz
update to v6.14.00 and apply build patch
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--fix_const_correctness.patch22
-rw-r--r--fix_use_of_tstring.patch51
4 files changed, 63 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 186653737ce1..39fcb1e1381e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = root
pkgdesc = C++ data analysis framework and interpreter from CERN.
- pkgver = 6.12.06
- pkgrel = 3
+ pkgver = 6.14.00
+ pkgrel = 1
url = http://root.cern.ch
install = root.install
arch = i686
@@ -38,20 +38,20 @@ pkgbase = root
optdepends = xrootd: XRootD support
optdepends = z3: Z3 Theorem prover support
options = !emptydirs
- source = https://root.cern.ch/download/root_v6.12.06.source.tar.gz
+ source = https://root.cern.ch/download/root_v6.14.00.source.tar.gz
source = root.install
source = root.sh
source = root.xml
source = rootd
source = settings.cmake
- source = fix_const_correctness.patch
- sha256sums = aedcfd2257806e425b9f61b483e25ba600eb0ea606e21262eafaa9dc745aa794
+ source = fix_use_of_tstring.patch
+ sha256sums = 7946430373489310c2791ff7a3520e393dc059db1371272bcd9d9cf0df347a0b
sha256sums = 72ba38e0faffa084ac2f787f360201f72b1733d27e36c3cb88eb2f3a4716fa61
sha256sums = 9d1f8e7ad923cb5450386edbbce085d258653c0160419cdd6ff154542cc32bd7
sha256sums = 50c08191a5b281a39aa05ace4feb8d5405707b4c54a5dcba061f954649c38cb0
sha256sums = 3c45b03761d5254142710b7004af0077f18efece7c95511910140d0542c8de8a
sha256sums = 70e1feaee9b94ca258b5add46098a4350766ff967fd270395a32c9acc19ead90
- sha256sums = 68f7007650e163bd337ecdf5a70fdfd683def5c10c07a6f26f3d41a572341511
+ sha256sums = 59d9e5b3647469fbb0b0cd5f159b7dbbe9257e479ed0c87d77ce73a384efa257
pkgname = root
diff --git a/PKGBUILD b/PKGBUILD
index 687e005765c3..674a15f0aa68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Sebastian Voecking < voeck at web dot de >
pkgname=root
-pkgver=6.12.06
-pkgrel=3
+pkgver=6.14.00
+pkgrel=1
pkgdesc='C++ data analysis framework and interpreter from CERN.'
arch=('i686' 'x86_64')
url='http://root.cern.ch'
@@ -49,21 +49,21 @@ source=("https://root.cern.ch/download/root_v${pkgver}.source.tar.gz"
'root.xml'
'rootd'
'settings.cmake'
- 'fix_const_correctness.patch')
-sha256sums=('aedcfd2257806e425b9f61b483e25ba600eb0ea606e21262eafaa9dc745aa794'
+ 'fix_use_of_tstring.patch')
+sha256sums=('7946430373489310c2791ff7a3520e393dc059db1371272bcd9d9cf0df347a0b'
'72ba38e0faffa084ac2f787f360201f72b1733d27e36c3cb88eb2f3a4716fa61'
'9d1f8e7ad923cb5450386edbbce085d258653c0160419cdd6ff154542cc32bd7'
'50c08191a5b281a39aa05ace4feb8d5405707b4c54a5dcba061f954649c38cb0'
'3c45b03761d5254142710b7004af0077f18efece7c95511910140d0542c8de8a'
'70e1feaee9b94ca258b5add46098a4350766ff967fd270395a32c9acc19ead90'
- '68f7007650e163bd337ecdf5a70fdfd683def5c10c07a6f26f3d41a572341511')
+ '59d9e5b3647469fbb0b0cd5f159b7dbbe9257e479ed0c87d77ce73a384efa257')
prepare() {
cd "${pkgname}-${pkgver}"
msg2 'Adjusting to Python3...'
2to3 -w etc/dictpch/makepch.py 2>&1 > /dev/null
- patch -p1 -i "${srcdir}/fix_const_correctness.patch"
+ patch -p1 -i "${srcdir}/fix_use_of_tstring.patch"
mkdir -p "${srcdir}/build"
cd "${srcdir}/build"
diff --git a/fix_const_correctness.patch b/fix_const_correctness.patch
deleted file mode 100644
index c74f42e1ba4f..000000000000
--- a/fix_const_correctness.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From e344f02dd86c04672355bbba88b1c0bee6d4edf4 Mon Sep 17 00:00:00 2001
-From: Axel Naumann <Axel.Naumann@cern.ch>
-Date: Tue, 8 May 2018 17:58:13 +0200
-Subject: [PATCH] Fix const-correctness (ROOT-9396).
-
----
- core/clingutils/res/TClingUtils.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/core/clingutils/res/TClingUtils.h b/core/clingutils/res/TClingUtils.h
-index da1a0e31751..c7e3e555122 100644
---- a/core/clingutils/res/TClingUtils.h
-+++ b/core/clingutils/res/TClingUtils.h
-@@ -276,7 +276,7 @@ class AnnotatedRecordDecl {
- }
-
- struct CompareByName {
-- bool operator() (const AnnotatedRecordDecl& right, const AnnotatedRecordDecl& left)
-+ bool operator() (const AnnotatedRecordDecl& right, const AnnotatedRecordDecl& left) const
- {
- return left.fNormalizedName < right.fNormalizedName;
- }
diff --git a/fix_use_of_tstring.patch b/fix_use_of_tstring.patch
new file mode 100644
index 000000000000..e800f456f957
--- /dev/null
+++ b/fix_use_of_tstring.patch
@@ -0,0 +1,51 @@
+From 5c1921a4be42c195c4490521de35774f5f1a2aa0 Mon Sep 17 00:00:00 2001
+From: Whitney Armstrong <whit@whit-armstrong.com>
+Date: Wed, 16 May 2018 09:10:19 -0500
+Subject: [PATCH] Fixed use of TString to compile with gcc 8.1 (#2012)
+
+Fixed use of TString to compile with gcc 8.1
+---
+ geom/gdml/src/TGDMLWrite.cxx | 2 +-
+ tmva/tmva/src/Factory.cxx | 2 +-
+ tmva/tmva/src/MethodCrossValidation.cxx | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/geom/gdml/src/TGDMLWrite.cxx b/geom/gdml/src/TGDMLWrite.cxx
+index 8d1231d5727..c64a1af3a75 100644
+--- a/geom/gdml/src/TGDMLWrite.cxx
++++ b/geom/gdml/src/TGDMLWrite.cxx
+@@ -1477,7 +1477,7 @@ XMLNodePointer_t TGDMLWrite::CreateElConeN(TGeoScaledShape * geoShape)
+ Double_t sy = geoShape->GetScale()->GetScale()[1];
+ Double_t ry1 = sy * rx1;
+
+- std::string format(TString::Format("%s/%s", fltPrecision.Data(), fltPrecision.Data()));
++ std::string format(TString::Format("%s/%s", fltPrecision.Data(), fltPrecision.Data()).Data());
+ fGdmlE->NewAttr(mainN, 0, "dx", TString::Format(format.c_str(), rx1, z));
+ fGdmlE->NewAttr(mainN, 0, "dy", TString::Format(format.c_str(), ry1, z));
+ fGdmlE->NewAttr(mainN, 0, "zmax", TString::Format(fltPrecision.Data(), zmax));
+diff --git a/tmva/tmva/src/Factory.cxx b/tmva/tmva/src/Factory.cxx
+index 857e5486535..ef5d3fcfbff 100644
+--- a/tmva/tmva/src/Factory.cxx
++++ b/tmva/tmva/src/Factory.cxx
+@@ -503,7 +503,7 @@ TMVA::MethodBase* TMVA::Factory::BookMethod(TMVA::DataLoader *loader, Types::EMV
+ TMVA::MethodBase* TMVA::Factory::BookMethodWeightfile(DataLoader *loader, TMVA::Types::EMVA methodType, const TString &weightfile)
+ {
+ TString datasetname = loader->GetName();
+- std::string methodTypeName = std::string(Types::Instance().GetMethodName(methodType));
++ std::string methodTypeName = std::string(Types::Instance().GetMethodName(methodType).Data());
+ DataSetInfo &dsi = loader->DefaultDataSetInfo();
+
+ IMethod *im = ClassifierFactory::Instance().Create(methodTypeName, dsi, weightfile );
+diff --git a/tmva/tmva/src/MethodCrossValidation.cxx b/tmva/tmva/src/MethodCrossValidation.cxx
+index 248d7422a63..02b0c4aa078 100644
+--- a/tmva/tmva/src/MethodCrossValidation.cxx
++++ b/tmva/tmva/src/MethodCrossValidation.cxx
+@@ -154,7 +154,7 @@ TMVA::MethodBase *
+ TMVA::MethodCrossValidation::InstantiateMethodFromXML(TString methodTypeName, TString weightfile) const
+ {
+ TMVA::MethodBase *m = dynamic_cast<MethodBase *>(
+- ClassifierFactory::Instance().Create(std::string(methodTypeName), DataInfo(), weightfile));
++ ClassifierFactory::Instance().Create(std::string(methodTypeName.Data()), DataInfo(), weightfile));
+
+ if (m->GetMethodType() == Types::kCategory) {
+ Log() << kFATAL << "MethodCategory not supported for the moment." << Endl;