summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-06-18 18:02:12 +0200
committeranthraxx2015-06-18 18:02:12 +0200
commitd51828b50617ef369affddb59b12b5a8b2d9e984 (patch)
treec425b0dc1b872336b0d218160bf89df6b38ca264
downloadaur-d51828b50617ef369affddb59b12b5a8b2d9e984.tar.gz
addpkg: ropgadget-git 5.4.348.282d851-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..667efb1acd24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ropgadget-git
+ pkgdesc = Search gadgets in binaries to facilitate ROP exploitation for several file formats and architectures
+ pkgver = 5.4.348.282d851
+ pkgrel = 1
+ url = http://www.shell-storm.org/project/ROPgadget
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-capstone
+ provides = ropgadget
+ conflicts = ropgadget
+ source = ropgadget-git::git+https://github.com/JonathanSalwan/ROPgadget
+ sha512sums = SKIP
+
+pkgname = ropgadget-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46c28b820ae3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Levente Polyak <levente[at]leventepolyak[dot]net>
+
+pkgname=ropgadget-git
+pkgver=5.4.348.282d851
+pkgrel=1
+pkgdesc="Search gadgets in binaries to facilitate ROP exploitation for several file formats and architectures"
+url="http://www.shell-storm.org/project/ROPgadget"
+arch=('any')
+license=('GPL2')
+depends=('python-capstone')
+makedepends=('git' 'python-setuptools')
+provides=('ropgadget')
+conflicts=('ropgadget')
+source=(${pkgname}::git+https://github.com/JonathanSalwan/ROPgadget)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0|cut -dv -f2)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+check() {
+ cd ${pkgname}/test-suite-binaries
+ ./test.sh
+}
+
+package() {
+ cd ${pkgname}
+ python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+}
+
+# vim:set ts=2 sw=2 et: