summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-06-19 00:59:59 +0200
committeranthraxx2016-06-19 00:59:59 +0200
commit04fa277d6b28e60b8665256cc9633015bda7808f (patch)
tree61c9196f692903bf91d1138e4e773a9bf68a0131
parente88e43f0bcc8a3581e405451784a2869491d23cb (diff)
downloadaur-ropper-git.tar.gz
upgpkg: ropper-git 1.10.0.432.5f44ac5-1 (dropped legacy sqlite dependency)
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ca9602b815..8bd6a9c1ec1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
# Generated by mksrcinfo v8
-# Fri Jun 17 14:49:59 UTC 2016
+# Sat Jun 18 22:59:59 UTC 2016
pkgbase = ropper-git
pkgdesc = Show information about binary files and find gadgets to build rop chains for different architectures
- pkgver = 1.9.10.421.c9ded96
+ pkgver = 1.10.0.432.5f44ac5
pkgrel = 1
url = https://github.com/sashs/Ropper
arch = any
license = GPL2
- checkdepends = sqlite
makedepends = git
makedepends = python-setuptools
makedepends = python-capstone
@@ -22,8 +21,7 @@ pkgbase = ropper-git
pkgname = ropper-git
depends = python
- depends = python-ropper
- optdepends = sqlite: gadgets database support
+ depends = python-ropper>=1.10.0.432.5f44ac5
optdepends = python-keystone: assemble command support
provides = ropper
conflicts = ropper
@@ -31,7 +29,6 @@ pkgname = ropper-git
pkgname = python-ropper-git
depends = python-capstone
depends = python-filebytes
- optdepends = sqlite: gadgets database support
optdepends = python-keystone: assemble command support
provides = python-ropper
conflicts = python-ropper
@@ -39,7 +36,6 @@ pkgname = python-ropper-git
pkgname = python2-ropper-git
depends = python2-capstone
depends = python2-filebytes
- optdepends = sqlite: gadgets database support
optdepends = python2-keystone: assemble command support
provides = python2-ropper
conflicts = python2-ropper
diff --git a/PKGBUILD b/PKGBUILD
index 3f8a5b84e54..b533c11b330 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
pkgbase=ropper-git
pkgname=('ropper-git' 'python-ropper-git' 'python2-ropper-git')
-pkgver=1.9.10.421.c9ded96
+pkgver=1.10.0.432.5f44ac5
pkgrel=1
pkgdesc='Show information about binary files and find gadgets to build rop chains for different architectures'
url='https://github.com/sashs/Ropper'
arch=('any')
license=('GPL2')
makedepends=('git' 'python-setuptools' 'python-capstone' 'python-filebytes' 'python2-setuptools' 'python2-capstone' 'python2-filebytes')
-checkdepends=('sqlite')
provides=('ropper')
conflicts=('ropper')
source=(${pkgbase}::git+https://github.com/sashs/Ropper)
@@ -44,11 +43,10 @@ check() {
}
package_ropper-git() {
- depends=('python' 'python-ropper')
+ depends=('python' "python-ropper>=${pkgver}")
provides=('ropper')
conflicts=('ropper')
- optdepends=('sqlite: gadgets database support'
- 'python-keystone: assemble command support')
+ optdepends=('python-keystone: assemble command support')
cd ${pkgbase}
python setup.py install -O1 --root="${pkgdir}" --skip-build
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
@@ -59,8 +57,7 @@ package_python-ropper-git() {
depends=('python-capstone' 'python-filebytes')
provides=('python-ropper')
conflicts=('python-ropper')
- optdepends=('sqlite: gadgets database support'
- 'python-keystone: assemble command support')
+ optdepends=('python-keystone: assemble command support')
cd ${pkgbase}
python setup.py install -O1 --root="${pkgdir}" --skip-build
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
@@ -72,8 +69,7 @@ package_python2-ropper-git() {
depends=('python2-capstone' 'python2-filebytes')
provides=('python2-ropper')
conflicts=('python2-ropper')
- optdepends=('sqlite: gadgets database support'
- 'python2-keystone: assemble command support')
+ optdepends=('python2-keystone: assemble command support')
cd ${pkgbase}-py2
python2 setup.py install -O1 --root="${pkgdir}" --skip-build
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"