summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Buchar2024-04-12 10:04:14 +0200
committerJan Buchar2024-04-12 10:11:48 +0200
commitc09914e6aa9580c1e4bf178a809002931da46ab6 (patch)
treea184b492897a8cfbc4cde5efdbed92f35ebc650b
downloadaur-c09914e6aa9580c1e4bf178a809002931da46ab6.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
-rw-r--r--requirements.txt36
-rw-r--r--rorqual3
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2e3d4cbe28f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = rorqual-venv
+ pkgdesc = A TUI Subsonic client
+ pkgver = 17
+ pkgrel = 1
+ url = https://github.com/janbuchar/rorqual
+ arch = any
+ makedepends = git
+ makedepends = python-pip
+ depends = python
+ depends = mpv
+ options = !strip
+ source = rorqual-17.tar.gz::https://github.com/janbuchar/rorqual/archive/refs/tags/release-17.tar.gz
+ source = requirements.txt
+ source = rorqual
+ sha256sums = 0019dfc4b32d63c1392aa264aed2253c1e0c2fb09216f8e2cc269bbfb8bb49b5
+ sha256sums = 4406a5c36530d108f96d4f8c307ccab6aa7213a3b383024699e7cc7f019bad66
+ sha256sums = 0936b5131a4a51a6f6a0b13c038e7fb1da720065aae5cea6fd4179184f1df6ca
+
+pkgname = rorqual-venv
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acb39f51c03a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=rorqual-venv
+_pkgname=rorqual
+pkgver=17
+pkgrel=1
+pkgdesc="A TUI Subsonic client"
+arch=(any)
+url="https://github.com/janbuchar/rorqual"
+makedepends=(git python-pip)
+depends=(python mpv)
+options=(!strip)
+
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/janbuchar/rorqual/archive/refs/tags/release-17.tar.gz"
+ "requirements.txt"
+ "rorqual")
+
+sha256sums=("0019dfc4b32d63c1392aa264aed2253c1e0c2fb09216f8e2cc269bbfb8bb49b5"
+ "4406a5c36530d108f96d4f8c307ccab6aa7213a3b383024699e7cc7f019bad66"
+ "0936b5131a4a51a6f6a0b13c038e7fb1da720065aae5cea6fd4179184f1df6ca")
+
+package() {
+ # Create virtualenv
+ export PIP_DISABLE_PIP_VERSION_CHECK=1
+ export PYTHONDONTWRITEBYTECODE=1
+ python -m venv "$pkgdir"/opt/rorqual/virtualenv
+ source "$pkgdir"/opt/rorqual/virtualenv/bin/activate
+
+ # Install dependencies
+ pip install --upgrade pip wheel
+ pip install -r requirements.txt
+
+ # Install rorqual
+ pushd $srcdir/${_pkgname}-release-${pkgver}
+ pip install .
+ popd
+
+ # Deactivate virtualenv
+ deactivate
+
+ # Install launcher script
+ install -Dm755 rorqual "$pkgdir"/usr/bin/rorqual
+}
diff --git a/requirements.txt b/requirements.txt
new file mode 100644
index 000000000000..0670ca5e3935
--- /dev/null
+++ b/requirements.txt
@@ -0,0 +1,36 @@
+anyio==3.6.2 ; python_version >= "3.10" and python_version < "3.12"
+certifi==2022.12.7 ; python_version >= "3.10" and python_version < "3.12"
+click==8.1.3 ; python_version >= "3.10" and python_version < "3.12"
+colorama==0.4.6 ; python_version >= "3.10" and python_version < "3.12" and platform_system == "Windows"
+emoji==1.7.0 ; python_version >= "3.10" and python_version < "3.12"
+h11==0.14.0 ; python_version >= "3.10" and python_version < "3.12"
+httpcore==0.17.0 ; python_version >= "3.10" and python_version < "3.12"
+httpx==0.24.0 ; python_version >= "3.10" and python_version < "3.12"
+idna==3.4 ; python_version >= "3.10" and python_version < "3.12"
+importlib-metadata==6.6.0 ; python_version >= "3.10" and python_version < "3.12"
+linkify-it-py==2.0.0 ; python_version >= "3.10" and python_version < "3.12"
+lxml==4.9.2 ; python_version >= "3.10" and python_version < "3.12"
+markdown-it-py==2.2.0 ; python_version >= "3.10" and python_version < "3.12"
+markdown-it-py[linkify,plugins]==2.2.0 ; python_version >= "3.10" and python_version < "3.12"
+mdit-py-plugins==0.3.5 ; python_version >= "3.10" and python_version < "3.12"
+mdurl==0.1.2 ; python_version >= "3.10" and python_version < "3.12"
+more-itertools==9.1.0 ; python_version >= "3.10" and python_version < "3.12"
+mpris-server==0.4.2 ; python_version >= "3.10" and python_version < "3.12"
+mpv==1.0.3 ; python_version >= "3.10" and python_version < "3.12"
+platformdirs==3.5.0 ; python_version >= "3.10" and python_version < "3.12"
+pycairo==1.23.0 ; python_version >= "3.10" and python_version < "3.12"
+pydantic==1.10.7 ; python_version >= "3.10" and python_version < "3.12"
+pydbus==0.6.0 ; python_version >= "3.10" and python_version < "3.12"
+pygments==2.15.1 ; python_version >= "3.10" and python_version < "3.12"
+pygobject==3.44.1 ; python_version >= "3.10" and python_version < "3.12"
+rich==13.3.5 ; python_version >= "3.10" and python_version < "3.12"
+setproctitle==1.3.2 ; python_version >= "3.10" and python_version < "3.12"
+sniffio==1.3.0 ; python_version >= "3.10" and python_version < "3.12"
+textual==0.22.3 ; python_version >= "3.10" and python_version < "3.12"
+tomli==2.0.1 ; python_version >= "3.10" and python_version < "3.12"
+typer==0.7.0 ; python_version >= "3.10" and python_version < "3.12"
+typing-extensions==4.5.0 ; python_version >= "3.10" and python_version < "3.12"
+uc-micro-py==1.0.1 ; python_version >= "3.10" and python_version < "3.12"
+unidecode==1.3.6 ; python_version >= "3.10" and python_version < "3.12"
+xsdata==22.12 ; python_version >= "3.10" and python_version < "3.12"
+zipp==3.15.0 ; python_version >= "3.10" and python_version < "3.12"
diff --git a/rorqual b/rorqual
new file mode 100644
index 000000000000..e1754b8588ce
--- /dev/null
+++ b/rorqual
@@ -0,0 +1,3 @@
+#!/bin/sh
+source /opt/rorqual/virtualenv/bin/activate
+python -m rorqual