summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKartik Mohta2018-06-03 16:20:48 -0400
committerKartik Mohta2018-06-03 16:20:48 -0400
commite33b20c94ff60efce3ba5d0ba44a1455c7d7f415 (patch)
tree9cc209ab03daaf54e45e5005d9c13bd04d5807e6
parent9e0c7725cad020de8287f4f0ec161c01ea5855c8 (diff)
downloadaur-e33b20c94ff60efce3ba5d0ba44a1455c7d7f415.tar.gz
Update for ROS melodic + use python3 packages
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD10
2 files changed, 30 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12bd2207f7f..36c9fc46c6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,42 +1,48 @@
pkgbase = ros-arch-deps
pkgdesc = Dependencies for building ROS on Arch
- pkgver = 1.11
- pkgrel = 2
+ pkgver = 1.14
+ pkgrel = 1
url = http://www.ros.org
arch = x86_64
arch = i686
license = BSD
depends = assimp
+ depends = boost
depends = cmake
depends = collada-dom
depends = console-bridge
depends = eigen
+ depends = fltk
+ depends = gazebo
depends = gtest
depends = log4cxx
depends = lz4
depends = ogre
depends = pcl
depends = poco
- depends = python2-dateutil
- depends = python2-empy
- depends = python2-netifaces
- depends = python2-nose
- depends = python2-opengl
- depends = python2-paramiko
- depends = python2-psutil
- depends = python2-pydot
- depends = python2-pyqt4
- depends = python2-rosdep
- depends = python2-rosinstall
- depends = python2-rosinstall-generator
- depends = python2-wstool
- depends = python2-yaml
- depends = qt4
+ depends = python-crypto
+ depends = python-dateutil
+ depends = python-defusedxml
+ depends = python-empy
+ depends = python-gnupg
+ depends = python-netifaces
+ depends = python-nose
+ depends = python-opengl
+ depends = python-paramiko
+ depends = python-psutil
+ depends = python-pydot
+ depends = python-pyqt5
+ depends = python-rosdep
+ depends = python-rosinstall
+ depends = python-rosinstall_generator
+ depends = python-wstool
+ depends = python-yaml
+ depends = qt5-base
depends = tango-icon-theme
depends = urdfdom
depends = yaml-cpp
- optdepends = python2-matplotlib: rqt_plot backend
- optdepends = python2-pyqtgraph: rqt_plot backend
+ optdepends = python-matplotlib: rqt_plot backend
+ optdepends = python-pyqtgraph: rqt_plot backend
pkgname = ros-arch-deps
diff --git a/PKGBUILD b/PKGBUILD
index 16e27429764..ae4d0338a8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
pkgname=ros-arch-deps
-pkgver=1.11
-pkgrel=2
+pkgver=1.14
+pkgrel=1
pkgdesc="Dependencies for building ROS on Arch"
url="http://www.ros.org"
arch=('x86_64' 'i686')
license=('BSD')
-depends=('assimp' 'cmake' 'collada-dom' 'console-bridge' 'eigen' 'gtest' 'log4cxx' 'lz4' 'ogre' 'pcl' 'poco' 'python2-dateutil' 'python2-empy' 'python2-netifaces' 'python2-nose' 'python2-opengl' 'python2-paramiko' 'python2-psutil' 'python2-pydot' 'python2-pyqt4' 'python2-rosdep' 'python2-rosinstall' 'python2-rosinstall-generator' 'python2-wstool' 'python2-yaml' 'qt4' 'tango-icon-theme' 'urdfdom' 'yaml-cpp')
+depends=('assimp' 'boost' 'cmake' 'collada-dom' 'console-bridge' 'eigen' 'fltk' 'gazebo' 'gtest' 'log4cxx' 'lz4' 'ogre' 'pcl' 'poco' 'python-crypto' 'python-dateutil' 'python-defusedxml' 'python-empy' 'python-gnupg' 'python-netifaces' 'python-nose' 'python-opengl' 'python-paramiko' 'python-psutil' 'python-pydot' 'python-pyqt5' 'python-rosdep' 'python-rosinstall' 'python-rosinstall_generator' 'python-wstool' 'python-yaml' 'qt5-base' 'tango-icon-theme' 'urdfdom' 'yaml-cpp')
optdepends=(
- 'python2-matplotlib: rqt_plot backend'
- 'python2-pyqtgraph: rqt_plot backend'
+ 'python-matplotlib: rqt_plot backend'
+ 'python-pyqtgraph: rqt_plot backend'
)
md5sums=()