summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-19 19:27:13 +0100
committerTim Rakowski2017-12-19 19:27:13 +0100
commita36d013205bfaa29842503dd5e00745b8c6f3762 (patch)
tree84a4bbd751ba8e029f25276b7dc0aeb968dc4b0f
downloadaur-a36d013205bfaa29842503dd5e00745b8c6f3762.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD61
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b59c103de008
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Dec 19 18:27:13 UTC 2017
+pkgbase = ros-ardent-ament-flake8
+ pkgdesc = ROS - The ability to check code for style and syntax conventions with flake8.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = Apache License 2.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ depends = python3-flake8
+ source = ros-ardent-ament-flake8-0.4.0-0.tar.gz::https://github.com/ros2-gbp/ament_lint-release/archive/release/ardent/ament_flake8/0.4.0-0.tar.gz
+ sha256sums = 2ea3a4ff8adcfaee152d33f3d007a7621cf0acdf41a57eb0fdcf042d26cec6e6
+
+pkgname = ros-ardent-ament-flake8
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fa6f47bd7d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The ability to check code for style and syntax conventions with flake8."
+url='http://www.ros.org/'
+
+pkgname='ros-ardent-ament-flake8'
+pkgver='0.4.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('Apache License 2.0')
+
+ros_makedepends=()
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ python3-flake8)
+
+# Git version (e.g. for debugging)
+# _tag=release/ardent/ament_flake8/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros2-gbp/ament_lint-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ament_lint-release-release-ardent-ament_flake8-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/ament_lint-release/archive/release/ardent/ament_flake8/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('2ea3a4ff8adcfaee152d33f3d007a7621cf0acdf41a57eb0fdcf042d26cec6e6')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
+
+ # Create build directory
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
+
+ # Build project
+ cmake "${srcdir}/${_dir}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
+ -DPYTHON_BASENAME=.cpython-35m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}