summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-21 23:29:56 +0100
committerTim Rakowski2017-12-21 23:29:56 +0100
commit3a4bc1864d12a05cd87d778ef212e0808a8b9ee8 (patch)
treecb79fd5c8c1d50c86e521bf0a1f280f8f23dc713
parent9419718d21c0b11734f09c71a3ca05765c5584f3 (diff)
downloadaur-ros-ardent-ament-index-python.tar.gz
Update to version 0.4.0-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD30
2 files changed, 3 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 354e84181392..5d9f6f5e943b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Dec 19 18:37:27 UTC 2017
+# Thu Dec 21 22:29:54 UTC 2017
pkgbase = ros-ardent-ament-index-python
pkgdesc = ROS - Python API to access the ament resource index.
pkgver = 0.4.0
diff --git a/PKGBUILD b/PKGBUILD
index 57577c07b398..cbf10424b1cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,33 +28,7 @@ _dir="ament_index-release-release-ardent-ament_index_python-${pkgver}-${_pkgver_
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/ament_index-release/archive/release/ardent/ament_index_python/${pkgver}-${_pkgver_patch}.tar.gz")
sha256sums=('b0937b9d89a8a7e6bebadc4c656481846478aade462af964a44c6fb65c4c7251')
-build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
-
- # Create build directory
- [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
- cd "${srcdir}/build"
-
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
-
- # Build project
- cmake "${srcdir}/${_dir}" \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
- -DPYTHON_BASENAME=.cpython-35m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF \
- -DCATKIN_ENABLE_TESTING=OFF
- make
-}
-
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/${_dir}"
+ python setup.py install --root="$pkgdir" --prefix="/opt/ros/ardent" --optimize=1
}