summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-19 19:39:04 +0100
committerTim Rakowski2017-12-19 19:39:04 +0100
commit636fca02ccc99f03469ee9ffc5db16892b833b32 (patch)
tree8878b5da0df511f176ff5b9ac8cdbaa7656ad8bb
downloadaur-636fca02ccc99f03469ee9ffc5db16892b833b32.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD62
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be2c32dff302
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Dec 19 18:39:04 UTC 2017
+pkgbase = ros-ardent-ament-package
+ pkgdesc = ROS - The parser for the manifest files in the ament buildsystem.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = Apache License 2.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ depends = python3-setuptools
+ depends = python3-pyparsing
+ source = ros-ardent-ament-package-0.4.0-0.tar.gz::https://github.com/ros2-gbp/ament_package-release/archive/release/ardent/ament_package/0.4.0-0.tar.gz
+ sha256sums = 2180cff34c1e6f218e90b5e7e137eefc65403469ed4ffe5147e516223480c457
+
+pkgname = ros-ardent-ament-package
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2588cfefd16e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The parser for the manifest files in the ament buildsystem."
+url='http://www.ros.org/'
+
+pkgname='ros-ardent-ament-package'
+pkgver='0.4.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('Apache License 2.0')
+
+ros_makedepends=()
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ python3-setuptools
+ python3-pyparsing)
+
+# Git version (e.g. for debugging)
+# _tag=release/ardent/ament_package/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros2-gbp/ament_package-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ament_package-release-release-ardent-ament_package-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/ament_package-release/archive/release/ardent/ament_package/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('2180cff34c1e6f218e90b5e7e137eefc65403469ed4ffe5147e516223480c457')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
+
+ # Create build directory
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
+
+ # Build project
+ cmake "${srcdir}/${_dir}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
+ -DPYTHON_BASENAME=.cpython-35m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}