summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-19 19:42:44 +0100
committerTim Rakowski2017-12-19 19:42:44 +0100
commita8b5a5d8d458a53c24d5fa7eb2d339d46e36ac45 (patch)
treee52caeb9953158ba780788a74b7966cb746ac397
downloadaur-a8b5a5d8d458a53c24d5fa7eb2d339d46e36ac45.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD62
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2dc41efb21a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Tue Dec 19 18:42:44 UTC 2017
+pkgbase = ros-ardent-pluginlib
+ pkgdesc = ROS - The pluginlib package provides tools for writing and dynamically loading plugins using the ROS build infrastructure.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://www.ros.org/wiki/pluginlib
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-ardent-ament-cmake
+ depends = ros-ardent-tinyxml2-vendor
+ depends = ros-ardent-ament-index-cpp
+ depends = ros-ardent-class-loader
+ source = ros-ardent-pluginlib-2.0.0-0.tar.gz::https://github.com/ros2-gbp/pluginlib-release/archive/release/ardent/pluginlib/2.0.0-0.tar.gz
+ sha256sums = ca5205cc927913caaad51823cdc67b0de04534deb284595c3c6a48865cb68646
+
+pkgname = ros-ardent-pluginlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0eeafc2a444e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The pluginlib package provides tools for writing and dynamically loading plugins using the ROS build infrastructure."
+url='http://www.ros.org/wiki/pluginlib'
+
+pkgname='ros-ardent-pluginlib'
+pkgver='2.0.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-ardent-ament-cmake)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-ardent-tinyxml2-vendor
+ ros-ardent-ament-index-cpp
+ ros-ardent-class-loader)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/ardent/pluginlib/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros2-gbp/pluginlib-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="pluginlib-release-release-ardent-pluginlib-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/pluginlib-release/archive/release/ardent/pluginlib/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('ca5205cc927913caaad51823cdc67b0de04534deb284595c3c6a48865cb68646')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
+
+ # Create build directory
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
+
+ # Build project
+ cmake "${srcdir}/${_dir}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
+ -DPYTHON_BASENAME=.cpython-35m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}