summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-19 19:42:46 +0100
committerTim Rakowski2017-12-19 19:42:46 +0100
commit9e37eded59bff28c5c42134c8576aa4ac11c620d (patch)
tree335dfc3cfddfc63270c028886b9e2a07de641076
downloadaur-9e37eded59bff28c5c42134c8576aa4ac11c620d.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD64
2 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9ae62c1a83a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Tue Dec 19 18:42:46 UTC 2017
+pkgbase = ros-ardent-poco-vendor
+ pkgdesc = ROS - CMake shim over the poco library.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = Apache License 2.0, Boost Software License 1.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ depends = expat
+ depends = zlib
+ depends = pcre
+ depends = sqlite
+ source = ros-ardent-poco-vendor-1.0.0-0.tar.gz::https://github.com/ros2-gbp/poco_vendor-release/archive/release/ardent/poco_vendor/1.0.0-0.tar.gz
+ sha256sums = 2d21ebb3da262bf26239d1fde5cb0a53422a831fce7cb8a839b58d4f6879d68b
+
+pkgname = ros-ardent-poco-vendor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f922c5d86d00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - CMake shim over the poco library."
+url='http://www.ros.org/'
+
+pkgname='ros-ardent-poco-vendor'
+pkgver='1.0.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('Apache License 2.0, Boost Software License 1.0')
+
+ros_makedepends=()
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ expat
+ zlib
+ pcre
+ sqlite)
+
+# Git version (e.g. for debugging)
+# _tag=release/ardent/poco_vendor/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros2-gbp/poco_vendor-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="poco_vendor-release-release-ardent-poco_vendor-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/poco_vendor-release/archive/release/ardent/poco_vendor/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('2d21ebb3da262bf26239d1fde5cb0a53422a831fce7cb8a839b58d4f6879d68b')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
+
+ # Create build directory
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
+
+ # Build project
+ cmake "${srcdir}/${_dir}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
+ -DPYTHON_BASENAME=.cpython-35m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}