summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-19 19:43:10 +0100
committerTim Rakowski2017-12-19 19:43:10 +0100
commit1754f4eae2e0bd9cd0f9a0a2cc76297aab0094b4 (patch)
tree9523017c70e3e0f839cd834f01a9fce0e41902e0
downloadaur-1754f4eae2e0bd9cd0f9a0a2cc76297aab0094b4.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD65
2 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43d41e6c96b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Tue Dec 19 18:43:10 UTC 2017
+pkgbase = ros-ardent-rclpy
+ pkgdesc = ROS - Package containing the Python client.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = Apache License 2.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-ardent-rmw-implementation-cmake
+ makedepends = ros-ardent-python-cmake-module
+ makedepends = ros-ardent-ament-cmake
+ makedepends = ros-ardent-rcutils
+ depends = ros-ardent-rmw-implementation
+ depends = ros-ardent-rcl
+ depends = ros-ardent-ament-index-python
+ source = ros-ardent-rclpy-0.4.0-0.tar.gz::https://github.com/ros2-gbp/rclpy-release/archive/release/ardent/rclpy/0.4.0-0.tar.gz
+ sha256sums = d31b275331e815ac8b24318f3f61fe3dd41e1a2e8443b132437f110966d8bedf
+
+pkgname = ros-ardent-rclpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3de009a36821
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Package containing the Python client."
+url='http://www.ros.org/'
+
+pkgname='ros-ardent-rclpy'
+pkgver='0.4.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('Apache License 2.0')
+
+ros_makedepends=(ros-ardent-rmw-implementation-cmake
+ ros-ardent-python-cmake-module
+ ros-ardent-ament-cmake
+ ros-ardent-rcutils)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-ardent-rmw-implementation
+ ros-ardent-rcl
+ ros-ardent-ament-index-python)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/ardent/rclpy/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros2-gbp/rclpy-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rclpy-release-release-ardent-rclpy-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/rclpy-release/archive/release/ardent/rclpy/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('d31b275331e815ac8b24318f3f61fe3dd41e1a2e8443b132437f110966d8bedf')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
+
+ # Create build directory
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
+
+ # Build project
+ cmake "${srcdir}/${_dir}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
+ -DPYTHON_BASENAME=.cpython-35m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}