summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-21 23:29:55 +0100
committerTim Rakowski2017-12-21 23:29:55 +0100
commit1cf44e5bd467ed1d9cbb299a47168c249cd822d9 (patch)
treed0df4c496890e6504c76e0137f1b054cdea9f6e6
parent8ec468c89eca3d71a1759956346cfa03e204c644 (diff)
downloadaur-ros-ardent-rosidl-typesupport-c.tar.gz
Update to version 0.4.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9348c56afc23..3ca42bc8b530 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Dec 19 18:45:01 UTC 2017
+# Thu Dec 21 22:29:47 UTC 2017
pkgbase = ros-ardent-rosidl-typesupport-c
pkgdesc = ROS - Generate the type support for C messages.
pkgver = 0.4.0
@@ -9,10 +9,14 @@ pkgbase = ros-ardent-rosidl-typesupport-c
license = Apache License 2.0
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-ardent-rosidl-generator-c
makedepends = ros-ardent-ament-cmake
- depends = ros-ardent-poco-vendor
+ depends = ros-ardent-rmw-implementation
+ depends = ros-ardent-rosidl-typesupport-introspection-c
depends = ros-ardent-rosidl-typesupport-interface
+ depends = ros-ardent-rosidl-generator-c
+ depends = ros-ardent-rosidl-typesupport-opensplice-c
+ depends = ros-ardent-poco-vendor
+ depends = ros-ardent-ament-cmake-core
depends = poco
source = ros-ardent-rosidl-typesupport-c-0.4.0-0.tar.gz::https://github.com/ros2-gbp/rosidl_typesupport-release/archive/release/ardent/rosidl_typesupport_c/0.4.0-0.tar.gz
sha256sums = d0e6e02da09173d68c418b01c42411479aa7d11bde95f34a75516ba1c336eb75
diff --git a/PKGBUILD b/PKGBUILD
index c371abe2ae00..049e9d26efc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,13 +10,17 @@ arch=('any')
pkgrel=1
license=('Apache License 2.0')
-ros_makedepends=(ros-ardent-rosidl-generator-c
- ros-ardent-ament-cmake)
+ros_makedepends=(ros-ardent-ament-cmake)
makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]})
-ros_depends=(ros-ardent-poco-vendor
- ros-ardent-rosidl-typesupport-interface)
+ros_depends=(ros-ardent-rmw-implementation
+ ros-ardent-rosidl-typesupport-introspection-c
+ ros-ardent-rosidl-typesupport-interface
+ ros-ardent-rosidl-generator-c
+ ros-ardent-rosidl-typesupport-opensplice-c
+ ros-ardent-poco-vendor
+ ros-ardent-ament-cmake-core)
depends=(${ros_depends[@]}
poco)
@@ -43,17 +47,14 @@ build() {
# Fix Python2/Python3 conflicts
/usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
+ export PYTHONPATH=/opt/ros/ardent/lib/python3.6/site-packages
+ export AMENT_PREFIX_PATH=/opt/ros/ardent
+
# Build project
cmake "${srcdir}/${_dir}" \
-DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
- -DPYTHON_BASENAME=.cpython-35m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF \
- -DCATKIN_ENABLE_TESTING=OFF
+ -DBUILD_TESTING=Off \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent
make
}