summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-19 19:45:04 +0100
committerTim Rakowski2017-12-19 19:45:04 +0100
commitf67ad161d2b5ccb400a2cce489cc93487f600840 (patch)
tree95ca5aa399dd4c709e2a13667a3cedd4bfadecd2
downloadaur-f67ad161d2b5ccb400a2cce489cc93487f600840.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD63
2 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca4833e31260
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Dec 19 18:45:04 UTC 2017
+pkgbase = ros-ardent-rosidl-typesupport-cpp
+ pkgdesc = ROS - Generate the type support for C++ messages.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = Apache License 2.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-ardent-rosidl-generator-c
+ makedepends = ros-ardent-ament-cmake
+ depends = ros-ardent-poco-vendor
+ depends = ros-ardent-rosidl-typesupport-interface
+ depends = poco
+ source = ros-ardent-rosidl-typesupport-cpp-0.4.0-0.tar.gz::https://github.com/ros2-gbp/rosidl_typesupport-release/archive/release/ardent/rosidl_typesupport_cpp/0.4.0-0.tar.gz
+ sha256sums = 31c8b5a969bb1237b4e5186246ec982166de4216f2124538de736f34aeff535b
+
+pkgname = ros-ardent-rosidl-typesupport-cpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3fd4a4eeac9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Generate the type support for C++ messages."
+url='http://www.ros.org/'
+
+pkgname='ros-ardent-rosidl-typesupport-cpp'
+pkgver='0.4.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('Apache License 2.0')
+
+ros_makedepends=(ros-ardent-rosidl-generator-c
+ ros-ardent-ament-cmake)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-ardent-poco-vendor
+ ros-ardent-rosidl-typesupport-interface)
+depends=(${ros_depends[@]}
+ poco)
+
+# Git version (e.g. for debugging)
+# _tag=release/ardent/rosidl_typesupport_cpp/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros2-gbp/rosidl_typesupport-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rosidl_typesupport-release-release-ardent-rosidl_typesupport_cpp-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/rosidl_typesupport-release/archive/release/ardent/rosidl_typesupport_cpp/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('31c8b5a969bb1237b4e5186246ec982166de4216f2124538de736f34aeff535b')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
+
+ # Create build directory
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
+
+ # Build project
+ cmake "${srcdir}/${_dir}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
+ -DPYTHON_BASENAME=.cpython-35m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}