summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-19 19:43:46 +0100
committerTim Rakowski2017-12-19 19:43:46 +0100
commitfb57bce1cd721d57da888288aef0412feacda8d7 (patch)
treec32f72b000b6f20da8c297ca7ebc53bf57abdb66
downloadaur-fb57bce1cd721d57da888288aef0412feacda8d7.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD66
2 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ccea68943954
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Tue Dec 19 18:43:46 UTC 2017
+pkgbase = ros-ardent-rosidl-typesupport-opensplice-cpp
+ pkgdesc = ROS - Generate the C++ interfaces for PrismTech OpenSplice.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = Apache License 2.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-ardent-rosidl-generator-cpp
+ makedepends = ros-ardent-rosidl-generator-c
+ makedepends = ros-ardent-opensplice-cmake-module
+ makedepends = ros-ardent-ament-cmake
+ makedepends = ros-ardent-rosidl-cmake
+ makedepends = opensplice
+ depends = ros-ardent-rosidl-typesupport-interface
+ depends = ros-ardent-rosidl-parser
+ source = ros-ardent-rosidl-typesupport-opensplice-cpp-0.4.0-0.tar.gz::https://github.com/ros2-gbp/rmw_opensplice-release/archive/release/ardent/rosidl_typesupport_opensplice_cpp/0.4.0-0.tar.gz
+ sha256sums = da0b40c4c0ca11ba02f7656f49e1cb5b4485488c4fca9290088d27ac709724e1
+
+pkgname = ros-ardent-rosidl-typesupport-opensplice-cpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd8955018ae4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Generate the C++ interfaces for PrismTech OpenSplice."
+url='http://www.ros.org/'
+
+pkgname='ros-ardent-rosidl-typesupport-opensplice-cpp'
+pkgver='0.4.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('Apache License 2.0')
+
+ros_makedepends=(ros-ardent-rosidl-generator-cpp
+ ros-ardent-rosidl-generator-c
+ ros-ardent-opensplice-cmake-module
+ ros-ardent-ament-cmake
+ ros-ardent-rosidl-cmake)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ opensplice)
+
+ros_depends=(ros-ardent-rosidl-typesupport-interface
+ ros-ardent-rosidl-parser)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/ardent/rosidl_typesupport_opensplice_cpp/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros2-gbp/rmw_opensplice-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rmw_opensplice-release-release-ardent-rosidl_typesupport_opensplice_cpp-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/rmw_opensplice-release/archive/release/ardent/rosidl_typesupport_opensplice_cpp/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('da0b40c4c0ca11ba02f7656f49e1cb5b4485488c4fca9290088d27ac709724e1')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
+
+ # Create build directory
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
+
+ # Build project
+ cmake "${srcdir}/${_dir}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
+ -DPYTHON_BASENAME=.cpython-35m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}