summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-19 19:45:12 +0100
committerTim Rakowski2017-12-19 19:45:12 +0100
commit4596751ee554b6a48131946f6815e8511c882a02 (patch)
treec9866925b7de8cc5ac0cc6e1dd8370ead9eafb61
downloadaur-4596751ee554b6a48131946f6815e8511c882a02.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD61
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64776fd898d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Dec 19 18:45:12 UTC 2017
+pkgbase = ros-ardent-rviz-assimp-vendor
+ pkgdesc = ROS - Wrapper around assimp, providing nothing but a dependency on assimp, on some systems.
+ pkgver = 2.0.0
+ pkgrel = 6
+ url = http://assimp.sourceforge.net/index.html
+ arch = any
+ license = Apache License 2.0, BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-ardent-ament-cmake
+ depends = assimp
+ source = ros-ardent-rviz-assimp-vendor-2.0.0-5.tar.gz::https://github.com/ros2-gbp/rviz-release/archive/release/ardent/rviz_assimp_vendor/2.0.0-5.tar.gz
+ sha256sums = ad3ffb869165452a8d11e5ab6c773ba466ccfd350d6734fce86bf105103ae517
+
+pkgname = ros-ardent-rviz-assimp-vendor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d722a39975a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Wrapper around assimp, providing nothing but a dependency on assimp, on some systems."
+url='http://assimp.sourceforge.net/index.html'
+
+pkgname='ros-ardent-rviz-assimp-vendor'
+pkgver='2.0.0'
+_pkgver_patch=5
+arch=('any')
+pkgrel=6
+license=('Apache License 2.0, BSD')
+
+ros_makedepends=(ros-ardent-ament-cmake)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ assimp)
+
+# Git version (e.g. for debugging)
+# _tag=release/ardent/rviz_assimp_vendor/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros2-gbp/rviz-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rviz-release-release-ardent-rviz_assimp_vendor-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/rviz-release/archive/release/ardent/rviz_assimp_vendor/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('ad3ffb869165452a8d11e5ab6c773ba466ccfd350d6734fce86bf105103ae517')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
+
+ # Create build directory
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
+
+ # Build project
+ cmake "${srcdir}/${_dir}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
+ -DPYTHON_BASENAME=.cpython-35m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}