summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-19 19:45:20 +0100
committerTim Rakowski2017-12-19 19:45:20 +0100
commit32a835b7b80462eae5e57e86a8d0f51c46b3468d (patch)
treefb393969bc9971b7ff7961d093535dbcb7471ca1
downloadaur-32a835b7b80462eae5e57e86a8d0f51c46b3468d.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD67
2 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52e57dea8186
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Tue Dec 19 18:45:20 UTC 2017
+pkgbase = ros-ardent-rviz-ogre-vendor
+ pkgdesc = ROS - Wrapper around ogre3d, it provides a fixed CMake module and an ExternalProject build of ogre.
+ pkgver = 2.0.0
+ pkgrel = 6
+ url = https://www.ogre3d.org/
+ arch = any
+ license = Apache License 2.0, MIT
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-ardent-ament-cmake
+ makedepends = pkg-config
+ makedepends = libfreetype6-dev
+ depends = libxaw
+ depends = libfreetype6
+ depends = libx11
+ depends = libxrandr
+ depends = mesa
+ source = ros-ardent-rviz-ogre-vendor-2.0.0-5.tar.gz::https://github.com/ros2-gbp/rviz-release/archive/release/ardent/rviz_ogre_vendor/2.0.0-5.tar.gz
+ sha256sums = a4633b652a8fef328a0765813c397b1d0bec0fcf5b65fdba2488e699495a3609
+
+pkgname = ros-ardent-rviz-ogre-vendor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1118ab3e3bd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Wrapper around ogre3d, it provides a fixed CMake module and an ExternalProject build of ogre."
+url='https://www.ogre3d.org/'
+
+pkgname='ros-ardent-rviz-ogre-vendor'
+pkgver='2.0.0'
+_pkgver_patch=5
+arch=('any')
+pkgrel=6
+license=('Apache License 2.0, MIT')
+
+ros_makedepends=(ros-ardent-ament-cmake)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ pkg-config
+ libfreetype6-dev)
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ libxaw
+ libfreetype6
+ libx11
+ libxrandr
+ mesa)
+
+# Git version (e.g. for debugging)
+# _tag=release/ardent/rviz_ogre_vendor/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros2-gbp/rviz-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rviz-release-release-ardent-rviz_ogre_vendor-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/rviz-release/archive/release/ardent/rviz_ogre_vendor/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('a4633b652a8fef328a0765813c397b1d0bec0fcf5b65fdba2488e699495a3609')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
+
+ # Create build directory
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
+
+ # Build project
+ cmake "${srcdir}/${_dir}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
+ -DPYTHON_BASENAME=.cpython-35m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}