summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-19 19:45:38 +0100
committerTim Rakowski2017-12-19 19:45:38 +0100
commita097781d5447dbf454f64100340d3656d917b4d2 (patch)
tree76549639c96cb7fd1d334e81664cb0183c035844
downloadaur-a097781d5447dbf454f64100340d3656d917b4d2.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD61
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2868f0c1689d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Dec 19 18:45:38 UTC 2017
+pkgbase = ros-ardent-teleop-twist-keyboard
+ pkgdesc = ROS - A robot-agnostic teleoperation node to convert keyboard commands to Twist messages.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://wiki.ros.org/teleop_twist_keyboard
+ arch = any
+ license = BSD License 2.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ depends = ros-ardent-geometry-msgs
+ depends = ros-ardent-rclpy
+ source = ros-ardent-teleop-twist-keyboard-2.0.0-0.tar.gz::https://github.com/ros2-gbp/teleop_twist_keyboard-release/archive/release/ardent/teleop_twist_keyboard/2.0.0-0.tar.gz
+ sha256sums = 6e85af1a3949be3a30bcc56536cbde6942352ab3fbb6a3e0a5508cde6bada653
+
+pkgname = ros-ardent-teleop-twist-keyboard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..017fe9e5fd42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - A robot-agnostic teleoperation node to convert keyboard commands to Twist messages."
+url='http://wiki.ros.org/teleop_twist_keyboard'
+
+pkgname='ros-ardent-teleop-twist-keyboard'
+pkgver='2.0.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD License 2.0')
+
+ros_makedepends=()
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-ardent-geometry-msgs
+ ros-ardent-rclpy)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/ardent/teleop_twist_keyboard/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros2-gbp/teleop_twist_keyboard-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="teleop_twist_keyboard-release-release-ardent-teleop_twist_keyboard-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/teleop_twist_keyboard-release/archive/release/ardent/teleop_twist_keyboard/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('6e85af1a3949be3a30bcc56536cbde6942352ab3fbb6a3e0a5508cde6bada653')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
+
+ # Create build directory
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
+
+ # Build project
+ cmake "${srcdir}/${_dir}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
+ -DPYTHON_BASENAME=.cpython-35m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}