summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 16:09:52 +0200
committerBenjamin Chrétien2015-06-20 02:25:12 +0900
commit4f1e121c80a28e825a7bff8f91c3a863ebd40acf (patch)
tree31d1ba47db90e467ee7abb6c0943e655447d96a5
parent485d13f74f8a958c0d3b624ec827ce42dbcc3316 (diff)
downloadaur-4f1e121c80a28e825a7bff8f91c3a863ebd40acf.tar.gz
indigo: use Python 2 rather than Python 3.
Since most packages are unlikely to be Python 3 ready before the next ROS distribution, we stick to Python 2.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rwxr-xr-ximport_catkin_packages.py4
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96893587fff4..2a13b1ce2adf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,11 +6,11 @@ pkgbase = ros-build-tools
arch = i686
arch = x86_64
license = BSD
- optdepends = python: package generation
- optdepends = python-catkin-pkg: package generation
- optdepends = python-termcolor: package generation
- optdepends = python-urllib3: package generation
- optdepends = python-yaml: package generation
+ optdepends = python2: package generation
+ optdepends = python2-catkin_pkg: package generation
+ optdepends = python2-termcolor: package generation
+ optdepends = python2-urllib3: package generation
+ optdepends = python2-yaml: package generation
source = fix-python-scripts.sh
source = stack-install-tools.sh
source = create-arch-ros-package-legacy.sh
@@ -27,7 +27,7 @@ pkgbase = ros-build-tools
md5sums = d257f7f20384e894b0431ee61068aa96
md5sums = 563c9d1320a3a997db25d3087303dcfb
md5sums = 8d6d7eb89a12c449497b209f1a06655b
- md5sums = 458ce5436e549235bfa295c5ab37eeaf
+ md5sums = 0f586e2cd92353f9e3cb6595d50f3fd2
md5sums = 07f5253eb3f8cb5295c32026a20ab6c0
pkgname = ros-build-tools
diff --git a/PKGBUILD b/PKGBUILD
index 46a173549f32..5dd0b23c828a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,11 +11,11 @@ pkgrel=1
license=('BSD')
makedepends=()
depends=()
-optdepends=('python: package generation'
- 'python-catkin-pkg: package generation'
- 'python-termcolor: package generation'
- 'python-urllib3: package generation'
- 'python-yaml: package generation')
+optdepends=('python2: package generation'
+ 'python2-catkin_pkg: package generation'
+ 'python2-termcolor: package generation'
+ 'python2-urllib3: package generation'
+ 'python2-yaml: package generation')
pkg_destination_dir="/usr/share/ros-build-tools"
@@ -47,5 +47,5 @@ md5sums=('ed01573e0ecc0f7ca451d7e2849cc5ee'
'd257f7f20384e894b0431ee61068aa96'
'563c9d1320a3a997db25d3087303dcfb'
'8d6d7eb89a12c449497b209f1a06655b'
- '458ce5436e549235bfa295c5ab37eeaf'
+ '0f586e2cd92353f9e3cb6595d50f3fd2'
'07f5253eb3f8cb5295c32026a20ab6c0')
diff --git a/import_catkin_packages.py b/import_catkin_packages.py
index 6aa4cf204870..7ab7b3ec8148 100755
--- a/import_catkin_packages.py
+++ b/import_catkin_packages.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python3
+#!/usr/bin/env python
# -*- coding: utf-8 -*-
from __future__ import print_function
@@ -624,7 +624,7 @@ def main():
default_python_version = {"fuerte": "2.7",
"groovy": "2.7",
"hydro": "2.7",
- "indigo": "3.4"}
+ "indigo": "2.7"}
python_version = default_python_version[options.distro]
if options.python_version != "":