summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-06-01 14:56:43 +0900
committerBenjamin Chrétien2015-06-20 02:25:13 +0900
commitf061a6caa2da41517bc4c15cabcad1b1c1dedd0c (patch)
treecc7d05d7a89ff6aca99fc70ef888929b57191e0b
parent820524250f65f1edd6078bf41999db8a6dc1a8b9 (diff)
downloadaur-f061a6caa2da41517bc4c15cabcad1b1c1dedd0c.tar.gz
import_catkin_packages.py: add Jade support.
-rwxr-xr-ximport_catkin_packages.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/import_catkin_packages.py b/import_catkin_packages.py
index e172887a10ee..93e0165bd91b 100755
--- a/import_catkin_packages.py
+++ b/import_catkin_packages.py
@@ -649,7 +649,8 @@ def main():
' to exclude from the generated PKGBUILD file.')
parser.add_option('--python-version', metavar='python_version', default='',
help='Python version that will be used. Accepted values are'
- ' 2.7 or 3. Note that Python 3 is only supported in Indigo.')
+ ' 2.7 or 3. Note that Python 3 is only supported in Indigo '
+ 'and Jade.')
parser.add_option('-f', '--force', dest='force', action='store_true',
default=False,
help='Always overwrite exiting PKGBUILD files.')
@@ -672,13 +673,15 @@ def main():
valid_python_versions = {"fuerte": ["2.7"],
"groovy": ["2.7"],
"hydro": ["2.7"],
- "indigo": ["2.7", "3.4"]}
+ "indigo": ["2.7", "3.4"],
+ "jade": ["2.7", "3.4"]}
# Default Python version that will be used
default_python_version = {"fuerte": "2.7",
"groovy": "2.7",
"hydro": "2.7",
- "indigo": "2.7"}
+ "indigo": "2.7",
+ "jade": "2.7"}
python_version = default_python_version[options.distro]
if options.python_version != "":