summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-04 20:37:28 +0200
committerBenjamin Chrétien2014-06-04 20:37:28 +0200
commitd38de46de8730b71026ddf95d1bc9be01dbbac12 (patch)
tree3386cf44cf201c59627f92cc33571f5d8220aa32
downloadaur-d38de46de8730b71026ddf95d1bc9be01dbbac12.tar.gz
indigo: first test (catkin).
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD60
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46005eea3d84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ros-indigo-catkin
+ pkgdesc = ROS - Low-level build system macros and infrastructure for ROS.
+ pkgver = 0.6.6
+ pkgrel = 1
+ url = http://www.ros.org/wiki/catkin
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = python-catkin-pkg
+ makedepends = python-empy
+ makedepends = python
+ depends = gtest
+ depends = python-nose
+ depends = python-catkin-pkg
+ depends = python-empy
+ depends = python
+ source = catkin::git+https://github.com/ros-gbp/catkin-release.git#tag=release/indigo/catkin/0.6.6-0
+ md5sums = SKIP
+
+pkgname = ros-indigo-catkin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac1f6e742e7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Low-level build system macros and infrastructure for ROS."
+url='http://www.ros.org/wiki/catkin'
+
+pkgname='ros-indigo-catkin'
+pkgver='0.6.6'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=()
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ python-catkin-pkg
+ python-empy
+ python)
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ gtest
+ python-nose
+ python-catkin-pkg
+ python-empy
+ python)
+
+_tag=release/indigo/catkin/${pkgver}-${_pkgver_patch}
+_dir=catkin
+source=("${_dir}"::"git+https://github.com/ros-gbp/catkin-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=OFF \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.4.so \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}