summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-05 00:17:20 +0200
committerBenjamin Chrétien2014-06-05 00:17:20 +0200
commit23271dfa546ddf4c8d183d3defb73519fc8fe6b9 (patch)
treed73c5a98af0445d5a6fb8c822f9d43057d401f6a
downloadaur-23271dfa546ddf4c8d183d3defb73519fc8fe6b9.tar.gz
indigo: add ros metapackage.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD52
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d39f3cfb7746
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ros-indigo-cmake-modules
+ pkgdesc = ROS - A common repository for CMake Modules which are not distributed with CMake but are commonly used by ROS packages.
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-indigo-catkin
+ source = cmake_modules::git+https://github.com/ros-gbp/cmake_modules-release.git#tag=release/indigo/cmake_modules/0.3.1-0
+ md5sums = SKIP
+
+pkgname = ros-indigo-cmake-modules
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40764e8ef925
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - A common repository for CMake Modules which are not distributed with CMake but are commonly used by ROS packages."
+url='http://www.ros.org/'
+
+pkgname='ros-indigo-cmake-modules'
+pkgver='0.3.1'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-indigo-catkin)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]})
+
+_tag=release/indigo/cmake_modules/${pkgver}-${_pkgver_patch}
+_dir=cmake_modules
+source=("${_dir}"::"git+https://github.com/ros-gbp/cmake_modules-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.4m.so \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}