summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 16:09:52 +0200
committerBenjamin Chrétien2014-06-07 16:09:55 +0200
commitafeb05a1762f0af98acdc2362167d7dcb3c8157a (patch)
treee4b8407b2355a62dd026095170e9b2518b88bcd0
parentb34affe6dcd620a50b910acb6e422e9cdf2259af (diff)
downloadaur-afeb05a1762f0af98acdc2362167d7dcb3c8157a.tar.gz
indigo: use Python 2 rather than Python 3.
Since most packages are unlikely to be Python 3 ready before the next ROS distribution, we stick to Python 2.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb2a79adeadb..9602e203bc16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-indigo-console-bridge
pkgdesc = ROS - Lightweight tool for forwarding output from libraries to other logging systems.
pkgver = 0.2.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ros/console_bridge
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index b968db7bf7f8..902c41094a88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-indigo-console-bridge'
pkgver='0.2.7'
_pkgver_patch=0
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=()
@@ -34,16 +34,16 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.4m.so \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}