summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 17:32:12 +0200
committerBenjamin Chrétien2014-06-07 17:32:12 +0200
commit0dbbfd8819cdf6456f0463d036ed2f7aac023808 (patch)
treee1b6efbf5ae9d86dba170e1ea1d621b5e81ccd63
downloadaur-0dbbfd8819cdf6456f0463d036ed2f7aac023808.tar.gz
indigo: add ros_core.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD55
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6d5d59a1cfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ros-indigo-diagnostic-msgs
+ pkgdesc = ROS - This package holds the diagnostic messages which provide the standardized interface for the diagnostic and runtime monitoring systems in ROS.
+ pkgver = 1.11.3
+ pkgrel = 2
+ url = http://ros.org/wiki/diagnostic_msgs
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-indigo-message-generation
+ makedepends = ros-indigo-catkin
+ makedepends = ros-indigo-std-msgs
+ depends = ros-indigo-std-msgs
+ depends = ros-indigo-message-runtime
+ source = diagnostic_msgs::git+https://github.com/ros-gbp/common_msgs-release.git#tag=release/indigo/diagnostic_msgs/1.11.3-1
+ md5sums = SKIP
+
+pkgname = ros-indigo-diagnostic-msgs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5566f4e0d451
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - This package holds the diagnostic messages which provide the standardized interface for the diagnostic and runtime monitoring systems in ROS."
+url='http://ros.org/wiki/diagnostic_msgs'
+
+pkgname='ros-indigo-diagnostic-msgs'
+pkgver='1.11.3'
+_pkgver_patch=1
+arch=('any')
+pkgrel=2
+license=('BSD')
+
+ros_makedepends=(ros-indigo-message-generation
+ ros-indigo-catkin
+ ros-indigo-std-msgs)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-indigo-std-msgs
+ ros-indigo-message-runtime)
+depends=(${ros_depends[@]})
+
+_tag=release/indigo/diagnostic_msgs/${pkgver}-${_pkgver_patch}
+_dir=diagnostic_msgs
+source=("${_dir}"::"git+https://github.com/ros-gbp/common_msgs-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}