summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Reignier2015-08-28 00:39:49 +0200
committerRomain Reignier2015-08-28 00:39:49 +0200
commitc6965d52eab2bc19d13a26749ef157654645d798 (patch)
tree308209bb62284f0cfdf76c927d8aaf4707c6aa5a
downloadaur-c6965d52eab2bc19d13a26749ef157654645d798.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD56
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b50908ecec21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ros-indigo-ecl-config
+ pkgdesc = ROS - These tools inspect and describe your system with macros, types and functions.
+ pkgver = 0.61.1
+ pkgrel = 1
+ url = http://wiki.ros.org/ecl_config
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-indigo-ecl-license
+ makedepends = ros-indigo-catkin
+ makedepends = ros-indigo-ecl-build
+ depends = ros-indigo-ecl-license
+ depends = ros-indigo-ecl-build
+ source = ecl_config::git+https://github.com/yujinrobot-release/ecl_lite-release.git#tag=release/indigo/ecl_config/0.61.1-0
+ md5sums = SKIP
+
+pkgname = ros-indigo-ecl-config
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b28e0c40b3c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - These tools inspect and describe your system with macros, types and functions."
+url='http://wiki.ros.org/ecl_config'
+
+pkgname='ros-indigo-ecl-config'
+pkgver='0.61.1'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-indigo-ecl-license
+ ros-indigo-catkin
+ ros-indigo-ecl-build)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-indigo-ecl-license
+ ros-indigo-ecl-build)
+depends=(${ros_depends[@]})
+
+_tag=release/indigo/ecl_config/${pkgver}-${_pkgver_patch}
+_dir=ecl_config
+source=("${_dir}"::"git+https://github.com/yujinrobot-release/ecl_lite-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}