summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Reignier2015-08-28 00:39:59 +0200
committerRomain Reignier2015-08-28 00:39:59 +0200
commitaf52926d1b5f79fb60fa72f1b69f40a6b12c731b (patch)
tree1366879b319a62d5f9f479ccfff9ef40365fd4e0
downloadaur-af52926d1b5f79fb60fa72f1b69f40a6b12c731b.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD54
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4a3af5a7b3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ros-indigo-ecl-mpl
+ pkgdesc = ROS - Metaprogramming tools move alot of runtime calculations to be shifted to compile time.
+ pkgver = 0.61.2
+ pkgrel = 1
+ url = http://wiki.ros.org/ecl_mpl
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-indigo-ecl-license
+ makedepends = ros-indigo-catkin
+ depends = ros-indigo-ecl-license
+ source = ecl_mpl::git+https://github.com/yujinrobot-release/ecl_core-release.git#tag=release/indigo/ecl_mpl/0.61.2-0
+ md5sums = SKIP
+
+pkgname = ros-indigo-ecl-mpl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9fe8ce7fdce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Metaprogramming tools move alot of runtime calculations to be shifted to compile time."
+url='http://wiki.ros.org/ecl_mpl'
+
+pkgname='ros-indigo-ecl-mpl'
+pkgver='0.61.2'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-indigo-ecl-license
+ ros-indigo-catkin)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-indigo-ecl-license)
+depends=(${ros_depends[@]})
+
+_tag=release/indigo/ecl_mpl/${pkgver}-${_pkgver_patch}
+_dir=ecl_mpl
+source=("${_dir}"::"git+https://github.com/yujinrobot-release/ecl_core-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}