summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 16:09:52 +0200
committerBenjamin Chrétien2014-06-07 16:09:55 +0200
commit203695f0dcb62c949451f55a9021cbe92e362a92 (patch)
treea7fc95859ccadb754e6355e19c5a5e0308862afd
parentafe4cd3d350eef6a7a22378c2bf92d48d5d6f70f (diff)
downloadaur-203695f0dcb62c949451f55a9021cbe92e362a92.tar.gz
indigo: use Python 2 rather than Python 3.
Since most packages are unlikely to be Python 3 ready before the next ROS distribution, we stick to Python 2.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea885d4b90e3..496d5f22a146 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = ros-indigo-genpy
pkgdesc = ROS - Python ROS message and service generators.
pkgver = 0.5.3
- pkgrel = 1
+ pkgrel = 2
url = http://www.ros.org/
arch = any
license = BSD
makedepends = cmake
makedepends = git
makedepends = ros-build-tools
- makedepends = ros-indigo-catkin
makedepends = ros-indigo-genmsg
+ makedepends = ros-indigo-catkin
depends = ros-indigo-genmsg
source = genpy::git+https://github.com/ros-gbp/genpy-release.git#tag=release/indigo/genpy/0.5.3-0
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 141c36932ba2..442de9d46ec6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@ pkgname='ros-indigo-genpy'
pkgver='0.5.3'
_pkgver_patch=0
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
-ros_makedepends=(ros-indigo-catkin
- ros-indigo-genmsg)
+ros_makedepends=(ros-indigo-genmsg
+ ros-indigo-catkin)
makedepends=('cmake' 'git' 'ros-build-tools'
${ros_makedepends[@]})
@@ -33,16 +33,16 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.4m.so \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}