summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Reignier2015-12-09 21:09:13 +0100
committerRomain Reignier2015-12-09 21:09:13 +0100
commit083c14fbda91f242a287142601298f097f23f4a0 (patch)
tree4e9eff46c8b089ea3e6421648e1bac99e0d98810
downloadaur-083c14fbda91f242a287142601298f097f23f4a0.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD56
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7facf458eebe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Dec 9 20:09:13 UTC 2015
+pkgbase = ros-indigo-hector-imu-attitude-to-tf
+ pkgdesc = ROS - hector_imu_attitude_to_tf is a lightweight node that can be used to publish the roll/pitch attitude angles reported via a imu message to tf.
+ pkgver = 0.3.4
+ pkgrel = 1
+ url = http://ros.org/wiki/hector_imu_attitude_to_tf
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-indigo-tf
+ makedepends = ros-indigo-roscpp
+ makedepends = ros-indigo-catkin
+ depends = ros-indigo-tf
+ depends = ros-indigo-roscpp
+ source = hector_imu_attitude_to_tf::git+https://github.com/tu-darmstadt-ros-pkg-gbp/hector_slam-release.git#tag=release/indigo/hector_imu_attitude_to_tf/0.3.4-0
+ md5sums = SKIP
+
+pkgname = ros-indigo-hector-imu-attitude-to-tf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6676a4a8de1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - hector_imu_attitude_to_tf is a lightweight node that can be used to publish the roll/pitch attitude angles reported via a imu message to tf."
+url='http://ros.org/wiki/hector_imu_attitude_to_tf'
+
+pkgname='ros-indigo-hector-imu-attitude-to-tf'
+pkgver='0.3.4'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-indigo-tf
+ ros-indigo-roscpp
+ ros-indigo-catkin)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-indigo-tf
+ ros-indigo-roscpp)
+depends=(${ros_depends[@]})
+
+_tag=release/indigo/hector_imu_attitude_to_tf/${pkgver}-${_pkgver_patch}
+_dir=hector_imu_attitude_to_tf
+source=("${_dir}"::"git+https://github.com/tu-darmstadt-ros-pkg-gbp/hector_slam-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}