summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Reignier2015-12-09 21:20:56 +0100
committerRomain Reignier2015-12-09 21:20:56 +0100
commit1f7e79b2ab42b1416e3dfd09b50d94712252122c (patch)
treec6a5bcb994449d20fd06a37366df2ba1026c0f78
downloadaur-1f7e79b2ab42b1416e3dfd09b50d94712252122c.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD57
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb287a353a9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Dec 9 20:20:56 UTC 2015
+pkgbase = ros-indigo-hector-slam-launch
+ pkgdesc = ROS - hector_slam_launch contains launch files for launching hector_slam with different robot systems/setups/postprocessing scenarios.
+ pkgver = 0.3.4
+ pkgrel = 1
+ url = http://ros.org/wiki/hector_slam_launch
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-indigo-catkin
+ depends = ros-indigo-hector-map-server
+ depends = ros-indigo-hector-geotiff
+ depends = ros-indigo-hector-geotiff-plugins
+ depends = ros-indigo-hector-trajectory-server
+ depends = ros-indigo-hector-mapping
+ source = hector_slam_launch::git+https://github.com/tu-darmstadt-ros-pkg-gbp/hector_slam-release.git#tag=release/indigo/hector_slam_launch/0.3.4-0
+ md5sums = SKIP
+
+pkgname = ros-indigo-hector-slam-launch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51b4a600a10a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - hector_slam_launch contains launch files for launching hector_slam with different robot systems/setups/postprocessing scenarios."
+url='http://ros.org/wiki/hector_slam_launch'
+
+pkgname='ros-indigo-hector-slam-launch'
+pkgver='0.3.4'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-indigo-catkin)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-indigo-hector-map-server
+ ros-indigo-hector-geotiff
+ ros-indigo-hector-geotiff-plugins
+ ros-indigo-hector-trajectory-server
+ ros-indigo-hector-mapping)
+depends=(${ros_depends[@]})
+
+_tag=release/indigo/hector_slam_launch/${pkgver}-${_pkgver_patch}
+_dir=hector_slam_launch
+source=("${_dir}"::"git+https://github.com/tu-darmstadt-ros-pkg-gbp/hector_slam-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}