summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 16:09:52 +0200
committerBenjamin Chrétien2014-06-07 16:09:55 +0200
commitb31b2148ee467a021c7002bce00aedc500bb4b76 (patch)
treec79bf4cdb158680ef34caf548376b0e153618bbb
parentdc94333f86be7095b8d65fe0502bcca3153e82e0 (diff)
downloadaur-b31b2148ee467a021c7002bce00aedc500bb4b76.tar.gz
indigo: use Python 2 rather than Python 3.
Since most packages are unlikely to be Python 3 ready before the next ROS distribution, we stick to Python 2.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 955d20f5d3d5..1251c76ff86b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-indigo-message-generation
pkgdesc = ROS - Package modeling the build-time dependencies for generating language bindings of messages.
pkgver = 0.2.10
- pkgrel = 1
+ pkgrel = 2
url = http://ros.org/wiki/message_generation
arch = any
license = BSD
@@ -9,10 +9,10 @@ pkgbase = ros-indigo-message-generation
makedepends = git
makedepends = ros-build-tools
makedepends = ros-indigo-catkin
- depends = ros-indigo-gencpp
depends = ros-indigo-genlisp
- depends = ros-indigo-genpy
depends = ros-indigo-genmsg
+ depends = ros-indigo-genpy
+ depends = ros-indigo-gencpp
source = message_generation::git+https://github.com/ros-gbp/message_generation-release.git#tag=release/indigo/message_generation/0.2.10-0
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 62b1abcd9b0c..c6fa427cfd00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,17 +7,17 @@ pkgname='ros-indigo-message-generation'
pkgver='0.2.10'
_pkgver_patch=0
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(ros-indigo-catkin)
makedepends=('cmake' 'git' 'ros-build-tools'
${ros_makedepends[@]})
-ros_depends=(ros-indigo-gencpp
- ros-indigo-genlisp
+ros_depends=(ros-indigo-genlisp
+ ros-indigo-genmsg
ros-indigo-genpy
- ros-indigo-genmsg)
+ ros-indigo-gencpp)
depends=(${ros_depends[@]})
_tag=release/indigo/message_generation/${pkgver}-${_pkgver_patch}
@@ -35,16 +35,16 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.4m.so \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}