summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2016-03-24 11:20:49 +0900
committerBenjamin Chrétien2016-03-24 11:20:49 +0900
commit7ecc2db4fad098290fec89d587e2bd327386ba75 (patch)
tree289ad12758d08acdcc9304905c3ff1a6d6ee34c1
parent865cd3c1d19a66cc14c82d8a5ccface7d72119c4 (diff)
downloadaur-ros-indigo-pluginlib.tar.gz
Update to version 1.10.2 (pkgrel 1)
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec06f6530a3d..5d9cebddcd64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
+# Generated by mksrcinfo v8
+# Thu Mar 24 02:20:41 UTC 2016
pkgbase = ros-indigo-pluginlib
pkgdesc = ROS - The pluginlib package provides tools for writing and dynamically loading plugins using the ROS build infrastructure.
- pkgver = 1.10.1
- pkgrel = 3
+ pkgver = 1.10.2
+ pkgrel = 1
url = http://www.ros.org/wiki/pluginlib
arch = any
- license = BSD, Boost Software License
+ license = BSD
makedepends = cmake
- makedepends = git
makedepends = ros-build-tools
makedepends = ros-indigo-roslib
makedepends = ros-indigo-cmake-modules
@@ -20,8 +21,8 @@ pkgbase = ros-indigo-pluginlib
depends = ros-indigo-class-loader
depends = boost
depends = tinyxml
- source = pluginlib::git+https://github.com/ros-gbp/pluginlib-release.git#tag=release/indigo/pluginlib/1.10.1-0
- md5sums = SKIP
+ source = ros-indigo-pluginlib-1.10.2-0.tar.gz::https://github.com/ros-gbp/pluginlib-release/archive/release/indigo/pluginlib/1.10.2-0.tar.gz
+ sha256sums = 271ae7f924231acf49b59bcb04a2dfaa175b5787f3ed9146de2285bfb04ef0af
pkgname = ros-indigo-pluginlib
diff --git a/PKGBUILD b/PKGBUILD
index e9ede7fdd836..7e65dabdf8c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,18 @@ pkgdesc="ROS - The pluginlib package provides tools for writing and dynamically
url='http://www.ros.org/wiki/pluginlib'
pkgname='ros-indigo-pluginlib'
-pkgver='1.10.1'
+pkgver='1.10.2'
_pkgver_patch=0
arch=('any')
-pkgrel=3
-license=('BSD, Boost Software License')
+pkgrel=1
+license=('BSD')
ros_makedepends=(ros-indigo-roslib
ros-indigo-cmake-modules
ros-indigo-rosconsole
ros-indigo-catkin
ros-indigo-class-loader)
-makedepends=('cmake' 'git' 'ros-build-tools'
+makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]}
boost
tinyxml)
@@ -27,10 +27,16 @@ depends=(${ros_depends[@]}
boost
tinyxml)
-_tag=release/indigo/pluginlib/${pkgver}-${_pkgver_patch}
-_dir=pluginlib
-source=("${_dir}"::"git+https://github.com/ros-gbp/pluginlib-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/indigo/pluginlib/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/pluginlib-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="pluginlib-release-release-indigo-pluginlib-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/pluginlib-release/archive/release/indigo/pluginlib/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('271ae7f924231acf49b59bcb04a2dfaa175b5787f3ed9146de2285bfb04ef0af')
build() {
# Use ROS environment variables