summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2016-03-24 11:22:34 +0900
committerBenjamin Chrétien2016-03-24 11:22:34 +0900
commit1a4c5ac8cfdfa01f0a57321c32389b1714083478 (patch)
tree6ee990386ac22c3983d6b55216deb9ab25ae18f8
parent7c68a016a3d2211194b48537eda9d141932b0f02 (diff)
downloadaur-1a4c5ac8cfdfa01f0a57321c32389b1714083478.tar.gz
Update to version 0.2.18 (pkgrel 1)
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d565d27d0ec..3526a96d966c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Mar 24 02:22:26 UTC 2016
pkgbase = ros-indigo-python-qt-binding
pkgdesc = ROS - This stack provides Python bindings for Qt.
- pkgver = 0.2.17
+ pkgver = 0.2.18
pkgrel = 1
url = http://ros.org/wiki/python_qt_binding
arch = any
- license = BSD, LGPL, GPL
+ license = BSD
makedepends = cmake
- makedepends = git
makedepends = ros-build-tools
makedepends = ros-indigo-catkin
makedepends = ros-indigo-rosbuild
makedepends = python2-pyqt4
makedepends = qt4
depends = python2-pyqt4
- source = python_qt_binding::git+https://github.com/ros-gbp/python_qt_binding-release.git#tag=release/indigo/python_qt_binding/0.2.17-0
- md5sums = SKIP
+ source = ros-indigo-python-qt-binding-0.2.18-0.tar.gz::https://github.com/ros-gbp/python_qt_binding-release/archive/release/indigo/python_qt_binding/0.2.18-0.tar.gz
+ sha256sums = 1d9303c53eb90f01f008dd74fb52a81bcc040c05c06c9b7ca7ec549ced54bd11
pkgname = ros-indigo-python-qt-binding
diff --git a/PKGBUILD b/PKGBUILD
index 997983804307..39b065501b7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@ pkgdesc="ROS - This stack provides Python bindings for Qt."
url='http://ros.org/wiki/python_qt_binding'
pkgname='ros-indigo-python-qt-binding'
-pkgver='0.2.17'
+pkgver='0.2.18'
_pkgver_patch=0
arch=('any')
pkgrel=1
-license=('BSD, LGPL, GPL')
+license=('BSD')
ros_makedepends=(ros-indigo-catkin
ros-indigo-rosbuild)
-makedepends=('cmake' 'git' 'ros-build-tools'
+makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]}
python2-pyqt4
qt4)
@@ -21,10 +21,16 @@ ros_depends=()
depends=(${ros_depends[@]}
python2-pyqt4)
-_tag=release/indigo/python_qt_binding/${pkgver}-${_pkgver_patch}
-_dir=python_qt_binding
-source=("${_dir}"::"git+https://github.com/ros-gbp/python_qt_binding-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/indigo/python_qt_binding/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/python_qt_binding-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="python_qt_binding-release-release-indigo-python_qt_binding-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/python_qt_binding-release/archive/release/indigo/python_qt_binding/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('1d9303c53eb90f01f008dd74fb52a81bcc040c05c06c9b7ca7ec549ced54bd11')
build() {
# Use ROS environment variables