summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 18:51:05 +0200
committerBenjamin Chrétien2014-06-07 18:51:05 +0200
commit1d9447571d46b05c10cbd923b257303466d6abc1 (patch)
tree34f2fd25a312bf098655a26f4fc4a3574843c9b9
downloadaur-1d9447571d46b05c10cbd923b257303466d6abc1.tar.gz
indigo: add viz.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD56
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8784f277a284
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ros-indigo-python-qt-binding
+ pkgdesc = ROS - This stack provides Python bindings for Qt.
+ pkgver = 0.2.13
+ pkgrel = 1
+ url = http://ros.org/wiki/python_qt_binding
+ arch = any
+ license = BSD, LGPL, GPL
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-indigo-catkin
+ makedepends = ros-indigo-rosbuild
+ makedepends = python2-pyqt4
+ makedepends = qt4
+ depends = python2-pyqt4
+ source = python_qt_binding::git+https://github.com/ros-gbp/python_qt_binding-release.git#tag=release/indigo/python_qt_binding/0.2.13-0
+ md5sums = SKIP
+
+pkgname = ros-indigo-python-qt-binding
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b3615d43fcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - This stack provides Python bindings for Qt."
+url='http://ros.org/wiki/python_qt_binding'
+
+pkgname='ros-indigo-python-qt-binding'
+pkgver='0.2.13'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD, LGPL, GPL')
+
+ros_makedepends=(ros-indigo-catkin
+ ros-indigo-rosbuild)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ python2-pyqt4
+ qt4)
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ python2-pyqt4)
+
+_tag=release/indigo/python_qt_binding/${pkgver}-${_pkgver_patch}
+_dir=python_qt_binding
+source=("${_dir}"::"git+https://github.com/ros-gbp/python_qt_binding-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}