summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-05-21 13:11:27 +0900
committerBenjamin Chrétien2015-05-21 13:11:27 +0900
commit2d0c7ff8407dac9b7861a1c932112c2cfbfee81f (patch)
treebf3e37b1f7554dd3f9872495d32cb0d7c1fc63fc
parent2ec486b517e5f5445d1ecec20cacdfbf3a39b381 (diff)
downloadaur-2d0c7ff8407dac9b7861a1c932112c2cfbfee81f.tar.gz
indigo: desktop_full update.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--pyqt411.patch110
3 files changed, 8 insertions, 126 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2077de246fd..dadf45d9caff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-indigo-python-qt-binding
pkgdesc = ROS - This stack provides Python bindings for Qt.
- pkgver = 0.2.14
- pkgrel = 5
+ pkgver = 0.2.16
+ pkgrel = 1
url = http://ros.org/wiki/python_qt_binding
arch = any
license = BSD, LGPL, GPL
@@ -13,10 +13,8 @@ pkgbase = ros-indigo-python-qt-binding
makedepends = python2-pyqt4
makedepends = qt4
depends = python2-pyqt4
- source = python_qt_binding::git+https://github.com/ros-gbp/python_qt_binding-release.git#tag=release/indigo/python_qt_binding/0.2.14-0
- source = pyqt411.patch
+ source = python_qt_binding::git+https://github.com/ros-gbp/python_qt_binding-release.git#tag=release/indigo/python_qt_binding/0.2.16-0
md5sums = SKIP
- md5sums = 1b9558147faf9231e59c9b0d0113d7f5
pkgname = ros-indigo-python-qt-binding
diff --git a/PKGBUILD b/PKGBUILD
index dd364a1544e1..bdf19b5d4984 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@ pkgdesc="ROS - This stack provides Python bindings for Qt."
url='http://ros.org/wiki/python_qt_binding'
pkgname='ros-indigo-python-qt-binding'
-pkgver='0.2.14'
+pkgver='0.2.16'
_pkgver_patch=0
arch=('any')
-pkgrel=5
+pkgrel=1
license=('BSD, LGPL, GPL')
ros_makedepends=(ros-indigo-catkin
@@ -23,21 +23,14 @@ depends=(${ros_depends[@]}
_tag=release/indigo/python_qt_binding/${pkgver}-${_pkgver_patch}
_dir=python_qt_binding
-source=("${_dir}"::"git+https://github.com/ros-gbp/python_qt_binding-release.git"#tag=${_tag}
- "pyqt411.patch")
-md5sums=('SKIP'
- '1b9558147faf9231e59c9b0d0113d7f5')
+source=("${_dir}"::"git+https://github.com/ros-gbp/python_qt_binding-release.git"#tag=${_tag})
+md5sums=('SKIP')
build() {
# Use ROS environment variables
source /usr/share/ros-build-tools/clear-ros-env.sh
[ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
- # Apply patch
- msg "Patching source code"
- cd ${srcdir}/${_dir}
- git apply ${srcdir}/pyqt411.patch
-
# Create build directory
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
@@ -53,6 +46,7 @@ build() {
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}
diff --git a/pyqt411.patch b/pyqt411.patch
deleted file mode 100644
index 7d4fda1cef6d..000000000000
--- a/pyqt411.patch
+++ /dev/null
@@ -1,110 +0,0 @@
-From 92f404ef8112448ac0a0ed04b031b348ff192b69 Mon Sep 17 00:00:00 2001
-From: Dirk Thomas <dthomas@osrfoundation.org>
-Date: Wed, 22 Apr 2015 18:10:02 -0700
-Subject: [PATCH] support PyQt4.11 and higher when built with configure-ng.py
-
----
- cmake/sip_configure.py | 53 +++++++++++++++++++++++++++++++++++++++++---------
- 1 file changed, 44 insertions(+), 9 deletions(-)
-
-diff --git a/cmake/sip_configure.py b/cmake/sip_configure.py
-index dc2020d..df3778b 100644
---- a/cmake/sip_configure.py
-+++ b/cmake/sip_configure.py
-@@ -2,7 +2,35 @@
- import re
- import subprocess
- import sys
--from PyQt4 import pyqtconfig
-+
-+import sipconfig
-+try:
-+ from PyQt4.pyqtconfig import Configuration
-+except ImportError:
-+ # PyQt >= 4.11 has no pyqtconfig module if built with configure-ng.py
-+ from PyQt4 import QtCore
-+
-+ class Configuration(sipconfig.Configuration):
-+ def __init__(self):
-+ qtconfig = subprocess.check_output(['qmake-qt4', '-query'], universal_newlines=True)
-+ qtconfig = dict(line.split(':', 1) for line in qtconfig.splitlines())
-+ pyqtconfig = {
-+ 'qt_archdata_dir': qtconfig['QT_INSTALL_DATA'],
-+ 'qt_data_dir': qtconfig['QT_INSTALL_DATA'],
-+ 'qt_dir': qtconfig['QT_INSTALL_PREFIX'],
-+ 'qt_inc_dir': qtconfig['QT_INSTALL_HEADERS'],
-+ 'qt_lib_dir': qtconfig['QT_INSTALL_LIBS'],
-+ 'qt_threaded': 1,
-+ 'qt_version': QtCore.QT_VERSION,
-+ 'qt_winconfig': 'shared',
-+ }
-+ sipconfig.Configuration.__init__(self, [pyqtconfig])
-+
-+ macros = sipconfig._default_macros.copy()
-+ macros['INCDIR_QT'] = qtconfig['QT_INSTALL_HEADERS']
-+ macros['LIBDIR_QT'] = qtconfig['QT_INSTALL_LIBS']
-+ macros['MOC'] = 'moc-qt4'
-+ self.set_build_macros(macros)
-
- if len(sys.argv) != 8:
- print('usage: %s build-dir sip-file output_dir include_dirs libs lib_dirs ldflags' % sys.argv[0])
-@@ -15,12 +43,18 @@
- build_file = 'pyqtscripting.sbf'
-
- # Get the PyQt configuration information.
--config = pyqtconfig.Configuration()
-+config = Configuration()
-
- # Get the extra SIP flags needed by the imported qt module. Note that
- # this normally only includes those flags (-x and -t) that relate to SIP's
- # versioning system.
--qt_sip_flags = config.pyqt_sip_flags
-+try:
-+ sip_dir = config.pyqt_sip_dir
-+ sip_flags = config.pyqt_sip_flags
-+except AttributeError:
-+ # sipconfig.Configuration does not have a pyqt_sip_dir or pyqt_sip_flags attribute
-+ sip_dir = sipconfig._pkg_config['default_sip_dir'] + '/PyQt4'
-+ sip_flags = QtCore.PYQT_CONFIGURATION['sip_flags']
-
- try:
- os.makedirs(build_dir)
-@@ -33,31 +67,32 @@
- config.sip_bin,
- '-c', build_dir,
- '-b', os.path.join(build_dir, build_file),
-- '-I', config.pyqt_sip_dir,
-+ '-I', sip_dir,
- '-w'
- ]
--cmd += qt_sip_flags.split(' ')
-+cmd += sip_flags.split(' ')
- cmd.append(sip_file)
- subprocess.check_call(cmd)
-
- # Create the Makefile. The QtModuleMakefile class provided by the
- # pyqtconfig module takes care of all the extra preprocessor, compiler and
- # linker flags needed by the Qt library.
--makefile = pyqtconfig.QtGuiModuleMakefile(
-+makefile = sipconfig.SIPModuleMakefile(
- dir=build_dir,
- configuration=config,
-- build_file=build_file
-+ build_file=build_file,
-+ qt=['QtCore', 'QtGui']
- )
-
- # hack to override makefile behavior which always prepend -l to libraries which is wrong for absolute paths
--default_platform_lib_function = pyqtconfig.QtGuiModuleMakefile.platform_lib
-+default_platform_lib_function = sipconfig.SIPModuleMakefile.platform_lib
-
-
- def custom_platform_lib_function(self, clib, framework=0):
- if os.path.isabs(clib):
- return clib
- return default_platform_lib_function(self, clib, framework)
--pyqtconfig.QtGuiModuleMakefile.platform_lib = custom_platform_lib_function
-+sipconfig.SIPModuleMakefile.platform_lib = custom_platform_lib_function
-
-
- # split paths on whitespace