summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-04-25 13:56:11 +0900
committerBenjamin Chrétien2015-04-25 13:56:11 +0900
commit2ec486b517e5f5445d1ecec20cacdfbf3a39b381 (patch)
tree135bee0f16557663eda1afb86f55b6e4a684dbf2
parent55d1be2d654f7314ddcf71b60a7e9ba99674d069 (diff)
downloadaur-2ec486b517e5f5445d1ecec20cacdfbf3a39b381.tar.gz
indigo: desktop_full update.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--pyqt411.patch89
3 files changed, 55 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da9f6e5ca790..d2077de246fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-indigo-python-qt-binding
pkgdesc = ROS - This stack provides Python bindings for Qt.
pkgver = 0.2.14
- pkgrel = 4
+ pkgrel = 5
url = http://ros.org/wiki/python_qt_binding
arch = any
license = BSD, LGPL, GPL
@@ -16,7 +16,7 @@ pkgbase = ros-indigo-python-qt-binding
source = python_qt_binding::git+https://github.com/ros-gbp/python_qt_binding-release.git#tag=release/indigo/python_qt_binding/0.2.14-0
source = pyqt411.patch
md5sums = SKIP
- md5sums = 49dd47f7971958fdca1c2ae06ab2f8bb
+ md5sums = 1b9558147faf9231e59c9b0d0113d7f5
pkgname = ros-indigo-python-qt-binding
diff --git a/PKGBUILD b/PKGBUILD
index 4551c82a1dfd..dd364a1544e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-indigo-python-qt-binding'
pkgver='0.2.14'
_pkgver_patch=0
arch=('any')
-pkgrel=4
+pkgrel=5
license=('BSD, LGPL, GPL')
ros_makedepends=(ros-indigo-catkin
@@ -26,7 +26,7 @@ _dir=python_qt_binding
source=("${_dir}"::"git+https://github.com/ros-gbp/python_qt_binding-release.git"#tag=${_tag}
"pyqt411.patch")
md5sums=('SKIP'
- '49dd47f7971958fdca1c2ae06ab2f8bb')
+ '1b9558147faf9231e59c9b0d0113d7f5')
build() {
# Use ROS environment variables
diff --git a/pyqt411.patch b/pyqt411.patch
index 9de01ea78344..7d4fda1cef6d 100644
--- a/pyqt411.patch
+++ b/pyqt411.patch
@@ -1,65 +1,54 @@
-commit 2a0bf86d5b88948fea2a6d4c7be0599b36d9ba0b
-Author: pallegro <hollense@cs.dal.ca>
-Date: Tue Aug 19 15:15:00 2014 -0300
+From 92f404ef8112448ac0a0ed04b031b348ff192b69 Mon Sep 17 00:00:00 2001
+From: Dirk Thomas <dthomas@osrfoundation.org>
+Date: Wed, 22 Apr 2015 18:10:02 -0700
+Subject: [PATCH] support PyQt4.11 and higher when built with configure-ng.py
- PyQt 4.11 compatibility
+---
+ cmake/sip_configure.py | 53 +++++++++++++++++++++++++++++++++++++++++---------
+ 1 file changed, 44 insertions(+), 9 deletions(-)
diff --git a/cmake/sip_configure.py b/cmake/sip_configure.py
-index dc2020d..7c0eec7 100644
+index dc2020d..df3778b 100644
--- a/cmake/sip_configure.py
+++ b/cmake/sip_configure.py
-@@ -2,7 +2,49 @@ import os
+@@ -2,7 +2,35 @@
import re
import subprocess
import sys
-from PyQt4 import pyqtconfig
++
+import sipconfig
+try:
+ from PyQt4.pyqtconfig import Configuration
+except ImportError:
-+ # PyQt>=4.11 has no pyqtconfig
-+ import PyQt4
++ # PyQt >= 4.11 has no pyqtconfig module if built with configure-ng.py
+ from PyQt4 import QtCore
++
+ class Configuration(sipconfig.Configuration):
-+ """The class that represents PyQt configuration values.
-+ """
+ def __init__(self):
-+ qtconfig = subprocess.check_output(["qmake-qt4", "-query"], universal_newlines=True)
-+ qtconfig = dict(x.split(":", 1) for x in qtconfig.splitlines())
-+
++ qtconfig = subprocess.check_output(['qmake-qt4', '-query'], universal_newlines=True)
++ qtconfig = dict(line.split(':', 1) for line in qtconfig.splitlines())
+ pyqtconfig = {
-+ "pyqt_config_args": "--confirm-license -v /usr/share/sip/PyQt4 --qsci-api -q /usr/bin/qmake-qt4",
-+ "pyqt_version": QtCore.PYQT_VERSION,
-+ "pyqt_version_str": QtCore.PYQT_VERSION_STR,
-+ "pyqt_bin_dir": PyQt4.__path__[0],
-+ "pyqt_mod_dir": PyQt4.__path__[0],
-+ "pyqt_sip_dir": "/usr/share/sip/PyQt4",
-+ "pyqt_modules": "QtCore QtGui", #... and many more
-+ "pyqt_sip_flags": QtCore.PYQT_CONFIGURATION['sip_flags'],
-+ "qt_version": QtCore.QT_VERSION,
-+ "qt_edition": "free",
-+ "qt_winconfig": "shared",
-+ "qt_framework": 0,
-+ "qt_threaded": 1,
-+ "qt_dir": qtconfig['QT_INSTALL_PREFIX'],
-+ "qt_data_dir": qtconfig['QT_INSTALL_DATA'],
-+ "qt_archdata_dir": qtconfig['QT_INSTALL_DATA'],
-+ "qt_inc_dir": qtconfig['QT_INSTALL_HEADERS'],
-+ "qt_lib_dir": qtconfig['QT_INSTALL_LIBS']
++ 'qt_archdata_dir': qtconfig['QT_INSTALL_DATA'],
++ 'qt_data_dir': qtconfig['QT_INSTALL_DATA'],
++ 'qt_dir': qtconfig['QT_INSTALL_PREFIX'],
++ 'qt_inc_dir': qtconfig['QT_INSTALL_HEADERS'],
++ 'qt_lib_dir': qtconfig['QT_INSTALL_LIBS'],
++ 'qt_threaded': 1,
++ 'qt_version': QtCore.QT_VERSION,
++ 'qt_winconfig': 'shared',
+ }
-+
++ sipconfig.Configuration.__init__(self, [pyqtconfig])
++
+ macros = sipconfig._default_macros.copy()
+ macros['INCDIR_QT'] = qtconfig['QT_INSTALL_HEADERS']
+ macros['LIBDIR_QT'] = qtconfig['QT_INSTALL_LIBS']
-+ macros['MOC'] = os.path.join(qtconfig['QT_INSTALL_BINS'], 'moc-qt4')
-+
-+ sipconfig.Configuration.__init__(self, [pyqtconfig])
++ macros['MOC'] = 'moc-qt4'
+ self.set_build_macros(macros)
-+
if len(sys.argv) != 8:
print('usage: %s build-dir sip-file output_dir include_dirs libs lib_dirs ldflags' % sys.argv[0])
-@@ -15,7 +57,7 @@ build_dir, sip_file, output_dir, include_dirs, libs, lib_dirs, ldflags = sys.arg
+@@ -15,12 +43,18 @@
build_file = 'pyqtscripting.sbf'
# Get the PyQt configuration information.
@@ -68,7 +57,31 @@ index dc2020d..7c0eec7 100644
# Get the extra SIP flags needed by the imported qt module. Note that
# this normally only includes those flags (-x and -t) that relate to SIP's
-@@ -43,21 +85,22 @@ subprocess.check_call(cmd)
+ # versioning system.
+-qt_sip_flags = config.pyqt_sip_flags
++try:
++ sip_dir = config.pyqt_sip_dir
++ sip_flags = config.pyqt_sip_flags
++except AttributeError:
++ # sipconfig.Configuration does not have a pyqt_sip_dir or pyqt_sip_flags attribute
++ sip_dir = sipconfig._pkg_config['default_sip_dir'] + '/PyQt4'
++ sip_flags = QtCore.PYQT_CONFIGURATION['sip_flags']
+
+ try:
+ os.makedirs(build_dir)
+@@ -33,31 +67,32 @@
+ config.sip_bin,
+ '-c', build_dir,
+ '-b', os.path.join(build_dir, build_file),
+- '-I', config.pyqt_sip_dir,
++ '-I', sip_dir,
+ '-w'
+ ]
+-cmd += qt_sip_flags.split(' ')
++cmd += sip_flags.split(' ')
+ cmd.append(sip_file)
+ subprocess.check_call(cmd)
+
# Create the Makefile. The QtModuleMakefile class provided by the
# pyqtconfig module takes care of all the extra preprocessor, compiler and
# linker flags needed by the Qt library.