summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlyx-x2017-02-25 22:43:38 +0100
committerlyx-x2017-02-25 22:43:38 +0100
commit7ad6e3e230c9f040997a434f467ce5f3796c57e8 (patch)
tree9fa9e3efa278bf3c0924741566c3ed0c3deba83a
parente2fd4f22e9aacda6df6cfea832cb8641e346a640 (diff)
downloadaur-ros-indigo-qt-gui-cpp.tar.gz
Update to 0.2.32, manual switch still from qmake5 to qmake4 needed
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40ad9f8b4276..c104651818cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Apr 14 05:24:52 UTC 2016
pkgbase = ros-indigo-qt-gui-cpp
pkgdesc = ROS - qt_gui_cpp provides the foundation for C++-bindings for qt_gui and creates bindings for every generator available.
- pkgver = 0.2.30
+ pkgver = 0.2.32
pkgrel = 1
url = http://ros.org/wiki/qt_gui_cpp
arch = any
@@ -17,8 +15,8 @@ pkgbase = ros-indigo-qt-gui-cpp
makedepends = pkg-config
depends = ros-indigo-qt-gui
depends = ros-indigo-pluginlib
- source = ros-indigo-qt-gui-cpp-0.2.30-0.tar.gz::https://github.com/ros-gbp/qt_gui_core-release/archive/release/indigo/qt_gui_cpp/0.2.30-0.tar.gz
- sha256sums = 353d603d69c43457bbd9950b4d5b91f097b1772d8d3dddf2509af97d4f30fc46
+ source = ros-indigo-qt-gui-cpp-0.2.32-0.tar.gz::https://github.com/ros-gbp/qt_gui_core-release/archive/release/indigo/qt_gui_cpp/0.2.32-0.tar.gz
+ sha256sums = 24d14352555852956c3581df5fda5c8dbb427577e46e23fc0e6d145955ec8e3b
pkgname = ros-indigo-qt-gui-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 770c5f3e7a72..651fd301cfd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgdesc="ROS - qt_gui_cpp provides the foundation for C++-bindings for qt_gui an
url='http://ros.org/wiki/qt_gui_cpp'
pkgname='ros-indigo-qt-gui-cpp'
-pkgver='0.2.30'
+pkgver='0.2.32'
_pkgver_patch=0
arch=('any')
pkgrel=1
@@ -32,7 +32,7 @@ depends=(${ros_depends[@]})
# Tarball version (faster download)
_dir="qt_gui_core-release-release-indigo-qt_gui_cpp-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/qt_gui_core-release/archive/release/indigo/qt_gui_cpp/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('353d603d69c43457bbd9950b4d5b91f097b1772d8d3dddf2509af97d4f30fc46')
+sha256sums=('24d14352555852956c3581df5fda5c8dbb427577e46e23fc0e6d145955ec8e3b')
build() {
# Use ROS environment variables
@@ -46,6 +46,8 @@ build() {
# Fix Python2/Python3 conflicts
/usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ sed -ie 's/<QWidget>/<QtGui>/g' ${srcdir}/${_dir}/include/qt_gui_cpp/plugin_context.h
+
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
@@ -56,7 +58,9 @@ build() {
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DPYTHON_BASENAME=-python2.7 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
+
make
+
}
package() {