summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Reignier2015-08-28 00:42:35 +0200
committerRomain Reignier2015-08-28 00:42:35 +0200
commitda54e92d6dda30a68b83ffb054ad23ac0bf2818f (patch)
treed2c441958b96344e974d4dc7007dbd9f1152af6f
downloadaur-da54e92d6dda30a68b83ffb054ad23ac0bf2818f.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD54
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fda4338e4941
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ros-indigo-rocon-ebnf
+ pkgdesc = ROS - Internal packaging of the 0.91 version of the simple python EBNF parser written by LParis.
+ pkgver = 0.1.23
+ pkgrel = 1
+ url = http://lparis45.free.fr/rp.html
+ arch = any
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-indigo-catkin
+ makedepends = python2-catkin-pkg
+ source = rocon_ebnf::git+https://github.com/yujinrobot-release/rocon_tools-release.git#tag=release/indigo/rocon_ebnf/0.1.23-0
+ md5sums = SKIP
+
+pkgname = ros-indigo-rocon-ebnf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c39766a5ad7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Internal packaging of the 0.91 version of the simple python EBNF parser written by LParis."
+url='http://lparis45.free.fr/rp.html'
+
+pkgname='ros-indigo-rocon-ebnf'
+pkgver='0.1.23'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('GPL')
+
+ros_makedepends=(ros-indigo-catkin)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ python2-catkin-pkg)
+
+ros_depends=()
+depends=(${ros_depends[@]})
+
+_tag=release/indigo/rocon_ebnf/${pkgver}-${_pkgver_patch}
+_dir=rocon_ebnf
+source=("${_dir}"::"git+https://github.com/yujinrobot-release/rocon_tools-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}