summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 16:09:52 +0200
committerBenjamin Chrétien2014-06-07 16:09:55 +0200
commitd5c9bd1b851978f8c460284d4d49b8e9fa374203 (patch)
tree5a11f85213b18b89ec2fbd12ddba8576e86947f2
parentdbed7a73427dadc0eb738e9648704d6d40acac16 (diff)
downloadaur-d5c9bd1b851978f8c460284d4d49b8e9fa374203.tar.gz
indigo: use Python 2 rather than Python 3.
Since most packages are unlikely to be Python 3 ready before the next ROS distribution, we stick to Python 2.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a39b4306f25..cd31933cae06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-indigo-rosbuild
pkgdesc = ROS - rosbuild contains scripts for managing the CMake-based build system for ROS.
pkgver = 1.11.1
- pkgrel = 2
+ pkgrel = 3
url = http://ros.org/wiki/rosbuild
arch = any
license = BSD
@@ -10,9 +10,9 @@ pkgbase = ros-indigo-rosbuild
makedepends = ros-build-tools
makedepends = ros-indigo-catkin
makedepends = pkg-config
- depends = ros-indigo-catkin
depends = ros-indigo-message-generation
depends = ros-indigo-message-runtime
+ depends = ros-indigo-catkin
source = rosbuild::git+https://github.com/ros-gbp/ros-release.git#tag=release/indigo/rosbuild/1.11.1-1
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1ae82b28891d..f24eab1fe4a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-indigo-rosbuild'
pkgver='1.11.1'
_pkgver_patch=1
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(ros-indigo-catkin)
@@ -15,9 +15,9 @@ makedepends=('cmake' 'git' 'ros-build-tools'
${ros_makedepends[@]}
pkg-config)
-ros_depends=(ros-indigo-catkin
- ros-indigo-message-generation
- ros-indigo-message-runtime)
+ros_depends=(ros-indigo-message-generation
+ ros-indigo-message-runtime
+ ros-indigo-catkin)
depends=(${ros_depends[@]})
_tag=release/indigo/rosbuild/${pkgver}-${_pkgver_patch}
@@ -35,16 +35,16 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.4m.so \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}