summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 16:09:52 +0200
committerBenjamin Chrétien2014-06-07 16:09:55 +0200
commitdbcbe945bc7e25d0d6149c6288190e1d9a4f5c0c (patch)
tree3ffc44c84223edbb144d47e5eff655d7bc2f370a
parentdab73a3f0be2369dc7c7c4fba6ed6ac206681c61 (diff)
downloadaur-dbcbe945bc7e25d0d6149c6288190e1d9a4f5c0c.tar.gz
indigo: use Python 2 rather than Python 3.
Since most packages are unlikely to be Python 3 ready before the next ROS distribution, we stick to Python 2.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9040bd7a69d5..dbed018d7d0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-indigo-rosclean
- pkgdesc = ROS - rosclean: cleanup filesystem resources (e.
+ pkgdesc = ROS - rosclean: cleanup filesystem resources (e.g.
pkgver = 1.11.1
- pkgrel = 2
+ pkgrel = 3
url = http://ros.org/wiki/rosclean
arch = any
license = BSD
@@ -9,7 +9,7 @@ pkgbase = ros-indigo-rosclean
makedepends = git
makedepends = ros-build-tools
makedepends = ros-indigo-catkin
- depends = python-rospkg
+ depends = python2-rospkg
source = rosclean::git+https://github.com/ros-gbp/ros-release.git#tag=release/indigo/rosclean/1.11.1-1
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1eff124f983a..2278b43ac422 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Script generated with import_catkin_packages.py
# For more information: https://github.com/bchretien/arch-ros-stacks
-pkgdesc="ROS - rosclean: cleanup filesystem resources (e."
+pkgdesc="ROS - rosclean: cleanup filesystem resources (e.g."
url='http://ros.org/wiki/rosclean'
pkgname='ros-indigo-rosclean'
pkgver='1.11.1'
_pkgver_patch=1
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(ros-indigo-catkin)
@@ -16,7 +16,7 @@ makedepends=('cmake' 'git' 'ros-build-tools'
ros_depends=()
depends=(${ros_depends[@]}
- python-rospkg)
+ python2-rospkg)
_tag=release/indigo/rosclean/${pkgver}-${_pkgver_patch}
_dir=rosclean
@@ -33,16 +33,16 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.4m.so \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}