summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 16:09:52 +0200
committerBenjamin Chrétien2014-06-07 16:09:55 +0200
commit84d7a3de1e426da68495c15fec291f632f6fb527 (patch)
tree17b5bc3a61e5670391fbb3b672d5509aa06e1fd7
parentb14bccf9aaa1ebea4ff267f27cace1efe435d1b0 (diff)
downloadaur-84d7a3de1e426da68495c15fec291f632f6fb527.tar.gz
indigo: use Python 2 rather than Python 3.
Since most packages are unlikely to be Python 3 ready before the next ROS distribution, we stick to Python 2.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e54ebb0fb58..e11ec2125dea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-indigo-roscreate
pkgdesc = ROS - roscreate contains a tool that assists in the creation of ROS filesystem resources.
pkgver = 1.11.1
- pkgrel = 2
+ pkgrel = 3
url = http://ros.org/wiki/roscreate
arch = any
license = BSD
@@ -9,7 +9,7 @@ pkgbase = ros-indigo-roscreate
makedepends = git
makedepends = ros-build-tools
makedepends = ros-indigo-catkin
- depends = python-rospkg
+ depends = python2-rospkg
source = roscreate::git+https://github.com/ros-gbp/ros-release.git#tag=release/indigo/roscreate/1.11.1-1
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 41eb171ec388..52d44c6afeb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-indigo-roscreate'
pkgver='1.11.1'
_pkgver_patch=1
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(ros-indigo-catkin)
@@ -16,7 +16,7 @@ makedepends=('cmake' 'git' 'ros-build-tools'
ros_depends=()
depends=(${ros_depends[@]}
- python-rospkg)
+ python2-rospkg)
_tag=release/indigo/roscreate/${pkgver}-${_pkgver_patch}
_dir=roscreate
@@ -33,16 +33,16 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.4m.so \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}