summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 17:32:12 +0200
committerBenjamin Chrétien2014-06-07 17:32:12 +0200
commit8917d6c5cc43c1db76cf74062765107a2db93900 (patch)
treec06ed3a28ce3ada3be11e29230cdd522d818d0d6
downloadaur-8917d6c5cc43c1db76cf74062765107a2db93900.tar.gz
indigo: add ros_core.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD53
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdc0c9c5ea55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ros-indigo-rosparam
+ pkgdesc = ROS - rosparam contains the rosparam command-line tool for getting and setting ROS Parameters on the Parameter Server using YAML-encoded files.
+ pkgver = 1.11.3
+ pkgrel = 1
+ url = http://ros.org/wiki/rosparam
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-indigo-catkin
+ depends = ros-indigo-rosgraph
+ depends = python2-yaml
+ source = rosparam::git+https://github.com/ros-gbp/ros_comm-release.git#tag=release/indigo/rosparam/1.11.3-0
+ md5sums = SKIP
+
+pkgname = ros-indigo-rosparam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a02f803fdfc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rosparam contains the rosparam command-line tool for getting and setting ROS Parameters on the Parameter Server using YAML-encoded files."
+url='http://ros.org/wiki/rosparam'
+
+pkgname='ros-indigo-rosparam'
+pkgver='1.11.3'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-indigo-catkin)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-indigo-rosgraph)
+depends=(${ros_depends[@]}
+ python2-yaml)
+
+_tag=release/indigo/rosparam/${pkgver}-${_pkgver_patch}
+_dir=rosparam
+source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}