summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 16:09:52 +0200
committerBenjamin Chrétien2014-06-07 16:09:55 +0200
commit0a09e89e18714948c8699240ec594fc5b5b40597 (patch)
tree28107a130153e2c9205b8b580aef9f092058cc86
parentc1335fd92e92b7e98da61f346e0ef7f6243c3e82 (diff)
downloadaur-0a09e89e18714948c8699240ec594fc5b5b40597.tar.gz
indigo: use Python 2 rather than Python 3.
Since most packages are unlikely to be Python 3 ready before the next ROS distribution, we stick to Python 2.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fdc7b70314f..7fa4dd969038 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-indigo-rostime
pkgdesc = ROS - Time and Duration implementations for C++ libraries, including roscpp.
pkgver = 0.5.0
- pkgrel = 2
+ pkgrel = 3
url = http://ros.org/wiki/rostime
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 72c7a08ea822..76bbf1573305 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-indigo-rostime'
pkgver='0.5.0'
_pkgver_patch=1
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(ros-indigo-cpp-common
@@ -35,16 +35,16 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.4m.so \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}