summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-08-07 18:21:21 +0200
committerBenjamin Chrétien2014-08-07 18:29:28 +0200
commit7a3748536b13218752f9bba285ffa2b36cbf795d (patch)
tree68462720027d8742b3d9f3a1e5dcfdf0635c1835
parent896df44c6d72cb34e2f2d109c195e1dcc831f8f5 (diff)
downloadaur-7a3748536b13218752f9bba285ffa2b36cbf795d.tar.gz
hydro/indigo: fix rviz bug with PySide.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f29b7c5143e0..e8e521c0a895 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-indigo-rviz
pkgdesc = ROS - 3D visualization tool for ROS.
pkgver = 1.11.3
- pkgrel = 1
+ pkgrel = 2
url = http://ros.org/wiki/rviz
arch = any
license = BSD, Creative Commons
diff --git a/PKGBUILD b/PKGBUILD
index 554932ae7cd0..4cb7a9fc52b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-indigo-rviz'
pkgver='1.11.3'
_pkgver_patch=0
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD, Creative Commons')
ros_makedepends=(ros-indigo-geometry-msgs
@@ -79,6 +79,11 @@ _dir=rviz
source=("${_dir}"::"git+https://github.com/ros-gbp/rviz-release.git"#tag=${_tag})
md5sums=('SKIP')
+# Fix PySide bug
+_cmake_options=(
+ -DPYTHON_BASENAME=-python2.7
+)
+
build() {
# Use ROS environment variables
source /usr/share/ros-build-tools/clear-ros-env.sh
@@ -99,7 +104,8 @@ build() {
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ ${_cmake_options[@]}
make
}