summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerry Lin2018-11-05 05:26:44 +0800
committerJerry Lin2018-11-05 05:26:44 +0800
commita79b1c04f5a9fb366091c2a1c593890c9f548330 (patch)
tree6a612947d4385b4ddd0ef4a6f9e0b2ab74e6d61d
parent2d2290af49e9e7674bef98019f8645c5c687f8d1 (diff)
downloadaur-a79b1c04f5a9fb366091c2a1c593890c9f548330.tar.gz
Fix ogre-1.9 dependency and library path. Bump the pkgrel.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
-rw-r--r--find-ogre.patch29
3 files changed, 52 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40b8004b43c4..ec6f70ed3e18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-indigo-rviz-plugin-tutorials
pkgdesc = ROS - Tutorials showing how to write plugins for RViz.
pkgver = 0.9.2
- pkgrel = 2
+ pkgrel = 3
url = http://ros.org/wiki/rviz_plugin_tutorials
arch = any
license = BSD
@@ -10,9 +10,12 @@ pkgbase = ros-indigo-rviz-plugin-tutorials
makedepends = ros-build-tools
makedepends = ros-indigo-rviz
makedepends = ros-indigo-catkin
+ depends = ogre-1.9
depends = ros-indigo-rviz
source = rviz_plugin_tutorials::git+https://github.com/ros-gbp/visualization_tutorials-release.git#tag=release/indigo/rviz_plugin_tutorials/0.9.2-0
- md5sums = SKIP
+ source = find-ogre.patch
+ sha256sums = SKIP
+ sha256sums = 5fabd1b72ebcaa98ed550eddfd9a5fbe48cdadbce182b33b40a9d53f7a473fdb
pkgname = ros-indigo-rviz-plugin-tutorials
diff --git a/PKGBUILD b/PKGBUILD
index 0a3dcd4c7834..428ce582119a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-indigo-rviz-plugin-tutorials'
pkgver='0.9.2'
_pkgver_patch=0
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(ros-indigo-rviz
@@ -16,12 +16,24 @@ makedepends=('cmake' 'git' 'ros-build-tools'
${ros_makedepends[@]})
ros_depends=(ros-indigo-rviz)
-depends=(${ros_depends[@]})
+depends=(
+ 'ogre-1.9'
+ ${ros_depends[@]}
+)
_tag=release/indigo/rviz_plugin_tutorials/${pkgver}-${_pkgver_patch}
_dir=rviz_plugin_tutorials
-source=("${_dir}"::"git+https://github.com/ros-gbp/visualization_tutorials-release.git"#tag=${_tag})
-md5sums=('SKIP')
+source=(
+ "${_dir}"::"git+https://github.com/ros-gbp/visualization_tutorials-release.git#tag=${_tag}"
+ 'find-ogre.patch'
+)
+sha256sums=('SKIP'
+ '5fabd1b72ebcaa98ed550eddfd9a5fbe48cdadbce182b33b40a9d53f7a473fdb')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ patch -Np1 -i ${srcdir}/find-ogre.patch
+}
build() {
# Use ROS environment variables
@@ -36,7 +48,8 @@ build() {
/usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
# Build project
- cmake ${srcdir}/${_dir} \
+ env PKG_CONFIG_PATH=/opt/OGRE-1.9/lib/pkgconfig \
+ cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
diff --git a/find-ogre.patch b/find-ogre.patch
new file mode 100644
index 000000000000..594dd27b01ca
--- /dev/null
+++ b/find-ogre.patch
@@ -0,0 +1,29 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 099caba..1f125e6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -4,9 +4,14 @@
+ ## First start with some standard catkin stuff.
+ cmake_minimum_required(VERSION 2.8.3)
+ project(rviz_plugin_tutorials)
++
++# Ogre
++find_package(PkgConfig REQUIRED)
++pkg_check_modules(OGRE OGRE)
++
+ find_package(catkin REQUIRED COMPONENTS rviz)
+ catkin_package()
+-include_directories(${catkin_INCLUDE_DIRS})
++include_directories(${catkin_INCLUDE_DIRS} ${OGRE_INCLUDE_DIRS})
+ link_directories(${catkin_LIBRARY_DIRS})
+
+ ## This plugin includes Qt widgets, so we must include Qt like so:
+@@ -53,7 +58,7 @@ add_library(${PROJECT_NAME} ${SOURCE_FILES})
+ ## library and names the actual file something like
+ ## "librviz_plugin_tutorials.so", or whatever is appropriate for your
+ ## particular OS.
+-target_link_libraries(${PROJECT_NAME} ${QT_LIBRARIES} ${catkin_LIBRARIES})
++target_link_libraries(${PROJECT_NAME} ${QT_LIBRARIES} ${catkin_LIBRARIES} ${OGRE_LIBRARIES})
+ ## END_TUTORIAL
+
+