summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 18:19:43 +0200
committerBenjamin Chrétien2014-06-07 18:19:43 +0200
commit550328fd6574f096782010ed530a4ad36dd32de6 (patch)
tree9d616d1188eaf11e7ee2a96fa7b5ba2118bc9bd0
downloadaur-ros-indigo-smach-msgs.tar.gz
indigo: add robot.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD55
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c755958a7717
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ros-indigo-smach-msgs
+ pkgdesc = ROS - this package contains a set of messages that are used by the introspection interfaces for smach.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-indigo-message-generation
+ makedepends = ros-indigo-catkin
+ makedepends = ros-indigo-std-msgs
+ depends = ros-indigo-std-msgs
+ depends = ros-indigo-message-runtime
+ source = smach_msgs::git+https://github.com/ros-gbp/executive_smach-release.git#tag=release/indigo/smach_msgs/2.0.0-0
+ md5sums = SKIP
+
+pkgname = ros-indigo-smach-msgs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..682af7a63512
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - this package contains a set of messages that are used by the introspection interfaces for smach."
+url='http://www.ros.org/'
+
+pkgname='ros-indigo-smach-msgs'
+pkgver='2.0.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-indigo-message-generation
+ ros-indigo-catkin
+ ros-indigo-std-msgs)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-indigo-std-msgs
+ ros-indigo-message-runtime)
+depends=(${ros_depends[@]})
+
+_tag=release/indigo/smach_msgs/${pkgver}-${_pkgver_patch}
+_dir=smach_msgs
+source=("${_dir}"::"git+https://github.com/ros-gbp/executive_smach-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}