summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 18:19:43 +0200
committerBenjamin Chrétien2014-06-07 18:19:43 +0200
commit16554667096fe3a9a65851ed2b1f379071aa82ed (patch)
tree8b208c2bbcab0f4f301258da8effde10cbe540d3
downloadaur-ros-indigo-smach-ros.tar.gz
indigo: add robot.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD60
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5dc47f2a6d22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = ros-indigo-smach-ros
+ pkgdesc = ROS - The smach_ros package contains extensions for the SMACH library to integrate it tightly with ROS.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-indigo-rostest
+ makedepends = ros-indigo-catkin
+ depends = ros-indigo-smach
+ depends = ros-indigo-std-msgs
+ depends = ros-indigo-rospy
+ depends = ros-indigo-std-srvs
+ depends = ros-indigo-rostopic
+ depends = ros-indigo-actionlib
+ depends = ros-indigo-actionlib-msgs
+ depends = ros-indigo-smach-msgs
+ source = smach_ros::git+https://github.com/ros-gbp/executive_smach-release.git#tag=release/indigo/smach_ros/2.0.0-0
+ md5sums = SKIP
+
+pkgname = ros-indigo-smach-ros
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f521e14699a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The smach_ros package contains extensions for the SMACH library to integrate it tightly with ROS."
+url='http://www.ros.org/'
+
+pkgname='ros-indigo-smach-ros'
+pkgver='2.0.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-indigo-rostest
+ ros-indigo-catkin)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-indigo-smach
+ ros-indigo-std-msgs
+ ros-indigo-rospy
+ ros-indigo-std-srvs
+ ros-indigo-rostopic
+ ros-indigo-actionlib
+ ros-indigo-actionlib-msgs
+ ros-indigo-smach-msgs)
+depends=(${ros_depends[@]})
+
+_tag=release/indigo/smach_ros/${pkgver}-${_pkgver_patch}
+_dir=smach_ros
+source=("${_dir}"::"git+https://github.com/ros-gbp/executive_smach-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}