summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-06-01 15:32:49 +0900
committerBenjamin Chrétien2015-06-01 15:38:54 +0900
commitdc70d75d348df109eb9ce94b6fee31260e698cc1 (patch)
treebe89aec4b6515aeaf664259573fe08bd438644ac
downloadaur-dc70d75d348df109eb9ce94b6fee31260e698cc1.tar.gz
jade: add ros package and its dependencies.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD61
2 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cdb9f3e1dcb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ros-jade-catkin
+ pkgdesc = ROS - Low-level build system macros and infrastructure for ROS.
+ pkgver = 0.6.14
+ pkgrel = 1
+ url = http://www.ros.org/wiki/catkin
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = python2-catkin_pkg
+ makedepends = python2-empy
+ makedepends = python2
+ depends = gtest
+ depends = python2-nose
+ depends = python2-catkin_pkg
+ depends = python2-empy
+ depends = python2
+ source = catkin::git+https://github.com/ros-gbp/catkin-release.git#tag=release/jade/catkin/0.6.14-0
+ md5sums = SKIP
+
+pkgname = ros-jade-catkin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3729b0a4c8cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Low-level build system macros and infrastructure for ROS."
+url='http://www.ros.org/wiki/catkin'
+
+pkgname='ros-jade-catkin'
+pkgver='0.6.14'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=()
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ python2-catkin_pkg
+ python2-empy
+ python2)
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ gtest
+ python2-nose
+ python2-catkin_pkg
+ python2-empy
+ python2)
+
+_tag=release/jade/catkin/${pkgver}-${_pkgver_patch}
+_dir=catkin
+source=("${_dir}"::"git+https://github.com/ros-gbp/catkin-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/jade/setup.bash ] && source /opt/ros/jade/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=OFF \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/jade \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}