summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-06-01 15:32:49 +0900
committerBenjamin Chrétien2015-06-01 15:38:54 +0900
commit2d75ef619fe3e1259c82379fe6a98527f9d603c5 (patch)
tree881579aae92de0b8105fc8d6ddcf59a353618fae
downloadaur-2d75ef619fe3e1259c82379fe6a98527f9d603c5.tar.gz
jade: add ros package and its dependencies.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD53
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4826cca396b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ros-jade-cmake-modules
+ pkgdesc = ROS - A common repository for CMake Modules which are not distributed with CMake but are commonly used by ROS packages.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-jade-catkin
+ source = cmake_modules::git+https://github.com/ros-gbp/cmake_modules-release.git#tag=release/jade/cmake_modules/0.4.0-0
+ md5sums = SKIP
+
+pkgname = ros-jade-cmake-modules
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f35b6d1d043
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - A common repository for CMake Modules which are not distributed with CMake but are commonly used by ROS packages."
+url='http://www.ros.org/'
+
+pkgname='ros-jade-cmake-modules'
+pkgver='0.4.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-jade-catkin)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]})
+
+_tag=release/jade/cmake_modules/${pkgver}-${_pkgver_patch}
+_dir=cmake_modules
+source=("${_dir}"::"git+https://github.com/ros-gbp/cmake_modules-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/jade/setup.bash ] && source /opt/ros/jade/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/jade \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}